Bug 14509 - Designer fails to create correct field types in *.designer.cs
Summary: Designer fails to create correct field types in *.designer.cs
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS Designer ()
Version: 4.1.10
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
Depends on:
Reported: 2013-09-06 18:45 UTC by Douglas Starnes
Modified: 2013-09-13 10:42 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Douglas Starnes 2013-09-06 18:45:54 UTC
When attempting to add a UISegmentedControl to the design surface of an iOS storyboard, the designer.cs file had a field of type UIView instead of UISegmentedControl.  I was able to fix it by changing the type of the field in the designer.cs file to UISegmentedControl but the file has a stern warning that this is not advised.  Unfortunately, I cannot reproduce this error.  I tried to add other controls and more segmented controls to the same project and they all worked fine. Starting a new project and adding segmented controls worked fine.
Comment 1 Alan McGovern 2013-09-13 10:42:43 UTC
I haven't been able to reproduce this particular issue. I think what you experienced was a rare race condition which can happen while the type system is being built for the very first time. We are tracking this internally already. We also have another feature being tracked which is to ensure that when an Outlet changes type we rewrite it correctly. Once this feature has been implemented we will be able to fix any outlets which have been incorrectly generated like this.

If you can reproduce this issue more reliably please re-open this bug and let us know how to do so. Thanks for reporting this anyway!