Bug 14416 - mdb doesn't match image
Summary: mdb doesn't match image
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger ()
Version: 1.6.x
Hardware: PC Windows
: Normal normal
Target Milestone: 1.8.x (VS2013)
Assignee: Dominique Louis
Depends on:
Reported: 2013-09-04 05:25 UTC by Dennis Schneider
Modified: 2016-05-10 17:02 UTC (History)
9 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Dennis Schneider 2013-09-04 05:25:34 UTC
Unfortunately I am facing a problem since I am using an embedded native library. After I was able to embedd a native c-library I faced the problem mentioned in the summary... At first I was able to debug the project successfully (also with the native library) but after several debugging-sessions Visual Studio says "mdb doesn't match image." 

Considering further output it seems like the .exe is not being (re-)build since it is producing output (by Console.WriteLine()) which is not being provided by newer source code anymore...
Comment 1 Dennis Schneider 2013-09-04 06:09:19 UTC
Update: Emptying the cache (/Users/{User}/Library/Caches/Xamarin/mtbs/builds/{Project}/) solved the problem of not rebuilding the project. But my breakpoints are still not being hit even though the output does not say "mdb doesn't match image." anymore...
Comment 2 Dominique Louis 2013-10-10 05:52:30 UTC
Hi Dennis, 
  A new Alpha with improved debugging will be out shortly. Once it is available, please let us know if this issue persists for you.
Comment 3 PJ 2013-10-24 16:42:20 UTC
The new Alpha 1.6 is available through the updater, based on comment 2 I'll mark as RESOLVED FIXED.

Dennis, if the update doesn't contain a fix for the issue as you're experiencing it, please REOPEN and, if possible, attach a small, buildable test case demonstrating the issue. This will ensure the quickest possible turnaround time on the fix.