Bug 14414 - Cleaning solution doesnt seem to work
Summary: Cleaning solution doesnt seem to work
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.3.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jose Miguel Torres
Depends on:
Reported: 2013-09-04 05:00 UTC by James Clancey
Modified: 2015-07-29 02:21 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description James Clancey 2013-09-04 05:00:15 UTC
I had some bad dll's refernces in my solution. I cleaned my solution after fixing it. The app still used the old dll's and crashed. I tried rebuilding nothing worked.

I also tried the same project in XS/mac and it worked perfectly.
Comment 1 Dominique Louis 2013-09-16 08:30:13 UTC
Jose, as you are doing end to end testing as part of the docs, can you see if you are able to repro this in iOS and the latest security-fix code base.
Comment 2 Jose Miguel Torres 2013-09-16 10:07:47 UTC
Hi James,

It's happening for all the projects or just one? On the other hand could you give further information about which version you are using and what kind of crash you are getting?


Comment 3 Arpit Jha 2015-07-29 02:20:14 UTC
As per comment 2 , James not answered asked info by Jose .

For now I am changing status of this issue to Resolved | NoResponse and also I am not able to reproduce at my end.

Feel free to reopen, If you are facing this issue again.

Environment Info:
Comment 4 Arpit Jha 2015-07-29 02:21:02 UTC
An update comment 3

Environement Info:
XI + Build Host:

Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.51641

Installed Version: Professional
Xamarin   3.11.823.0 (079165f)
Visual Studio extension to enable development for Xamarin.iOS and

Xamarin.Android (f98871a95a479f6d71b3067b7e5834d41fcb2118)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS (1ebb3ca75e5ea92595284cb84c7d29c6e09ce324)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration