Bug 14413 - Crazy issues with mixed up dll references.
Summary: Crazy issues with mixed up dll references.
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger ()
Version: 1.3.x
Hardware: PC Windows
: Normal normal
Target Milestone: 1.12 (Merge)
Assignee: Dominique Louis
Depends on:
Reported: 2013-09-04 04:43 UTC by James Clancey
Modified: 2016-05-10 17:02 UTC (History)
11 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description James Clancey 2013-09-04 04:43:24 UTC
I use my own custom MT.D.

My App has a project reference to my MT.D.

My lib, auto added a reference to the built in monotouchdialog-1.dll

When I ran the build, it compiled everything fine. At run time it was blowing up without giving me any real error. Just there was an issue at my static main.

When I ran the same code in XS it told me there was an error casting types which let me know the real problem. 

The debugger on VS should tell me the same error.
Comment 1 PJ 2013-10-07 15:53:01 UTC
Hey James, any chance you could zip up your repro project with the custom MT.D?

I'd like to see if this is still a problem.
Comment 2 PJ 2013-10-29 10:22:46 UTC
No response yet, although that doesn't really mean it's gone. I can't track this down before the release myself, so if you do have a repro please attach!
Comment 3 James Clancey 2013-10-29 13:06:06 UTC
Pj, try the sample for https://github.com/Clancey/FlyoutNavigation
Comment 4 James Clancey 2013-10-29 13:08:01 UTC
IT is easily caused by referencing MT.D in source from either the lib or the sample. Then referencing the built in one in the other repo. Flyout is doing that right now.
Comment 5 Marek Habersack 2013-11-04 08:25:47 UTC
This one might be fixed in the current master + 1.8 builds, following Alan's changes which removed the custom assembly resolver we had in the MTVS tasks. James, can you retest?
Comment 6 Alan McGovern 2013-11-06 20:20:49 UTC
This has been fixed. We let MSBuild resolve all the references for us now.
Comment 7 Prashant manu 2014-02-04 07:23:46 UTC
I have checked this issue with following builds:

All Windows and Mac
VS 2013/2012/2010
X.S 4.2.3(build 54)
Xamarin for VS 1.12.207

I have run the attached sample which is mentioned in Comment#3. I am successfully able to run the application on both Windows and Mac.

Please let me know it is correct behavior or not?
Comment 8 Saurabh 2014-05-09 08:56:24 UTC
I have checked this issue with attached sample in Comment3, I am able to build and run this sample successfully. Also in Comment 7, Prashant was able to build and deploy the sample successfully.

VS 2013
Xamarin for VS 1.12.278

Please let me know if I have to check any this else to verify this issue.

As of now, I am closing this issue.