Bug 14259 - We are not able to open Twitter, getting "Twitter not available. Try again later" for mobile sample "MWC" iOS sample"
Summary: We are not able to open Twitter, getting "Twitter not available. Try again la...
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples ()
Version: 6.3.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Oleg Demchenko
Depends on:
Reported: 2013-08-27 02:59 UTC by narayanp
Modified: 2014-01-24 08:44 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description narayanp 2013-08-27 02:59:06 UTC
Steps to reproduce:
1. Open mobile sample "MWC" iOS sample".
2. Debug or run the sample.
3. click on Twitter

Actual Result: it is showing "Twitter not available. Try again later" on all iOS devices and Simulators.

Expected Result: Twitter logging page should displayed after clicking on Twitter.

Supplement info:
Application Output: https://gist.github.com/saurabh360/09578271e986bf21960a
iOS Device log: https://gist.github.com/saurabh360/4bb35b65e6c88ab2cafa

Environment details: 
All Mac
X.S 4.1.9(build 6)
Mono 3.2.2
X.iOS 6.4.4-12

Device info:
All physical devices and All Simulators

Xcode info:
Xcode 4.5 and Xcode 4.6

App Info:
MobileSample-master/MWC iOS sample

Regression Status:
Same behavior happening with stable iOS, we are not sure it has worked before on previous build or not.
Comment 1 Sebastien Pouliot 2013-08-27 08:42:19 UTC
2013-08-29 17:52:33.719 MWCiOS[313:5007] ERROR saving downloaded XML: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Net.WebException: The remote server returned an error: (410) Gone.

^ (410) Gone

Looks like the app is using an old deprecated API* to access Twitter. You should remove this feature from your test plan or ask the author(s) if they want to update the sample (so it stays a good application reference for customers).

* According to [1] this v1 API was removed in March 5th, 2013 - so it likely never worked since then.

[1] http://drupalmotion.com/article/twitter-api-v1-will-be-410-gone
Comment 2 GouriKumari 2013-12-06 18:27:56 UTC

Could you take a look at the twitter functionality of "MWS" iOS sample and update it accordingly or assign this bug to the right person.  Please refer Comment #1 for further details regarding the bug.
Comment 3 Oleg Demchenko 2014-01-23 19:29:16 UTC
Update twitter functionality. Fix commits for this bug: adf1c90dcfa4d0b469279e8511b30e348b2c086e - e0e32bbac9efaa4a981936269e081ae04cfc5a25
Comment 4 Mohit Kheterpal 2014-01-24 08:44:18 UTC
Now for mobile sample "MWC" iOS sample" , twitter opens correctly on iOS device and simulator. Screencast: http://screencast.com/t/fiJ5UPIuV

Device Used:
iPhone 4 (iOS 7.04)

Environment info:
Xamarin Studio
Version 4.2.3 (build 154)
Build Information
Release ID: 402030154
Git revision: 4dca4a28d7ecc2c4df8a4d58e74b8902d0283b53
Xamarin addins: cc120a6f639fa6649aa4d23a0f0e7c5701134047

Hash: 094bb4e

Sample Git version