Bug 14175 - Xamarin Studio renders Consolas font incorrectly
Summary: Xamarin Studio renders Consolas font incorrectly
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.0.10
Hardware: PC Mac OS
: Low trivial
Target Milestone: master
Assignee: Cody Russell
Depends on:
Reported: 2013-08-22 00:45 UTC by Prashant Cholachagudda
Modified: 2017-07-21 09:37 UTC (History)
6 users (show)

Tags: gtk osx
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Prashant Cholachagudda 2013-08-22 00:45:09 UTC
Xamarin Studio renders Consolas font incorrectly/cuts off.
The problem doesn't seem to exist if the default Menlo font is used for instance.
Comment 1 Prashant Cholachagudda 2013-08-22 00:46:04 UTC
Preview: http://i.imgur.com/rzQuOny.png
Comment 2 Mike Krüger 2013-08-27 00:55:52 UTC
should work in newer versions
Comment 3 Christian Ehrhardt 2013-09-21 14:38:53 UTC
Every font I've tried has this problem in 4.0.12 as per Mike Krugers comment I tried 4.1.0 beta and 4.1.11 alpha and the problem still exists.
Comment 4 Nischal 2014-01-21 07:19:10 UTC
We have checked this with Consolas font for Texteditor and getting same behavior. Text appears cut off or missing. 
Screencast: http://screencast.com/t/LK3x0cjVhL1

Hence reopening this issue.

Environment info:
Xamarin Studio
Version 4.2.3 (build 146)
Git revision: 76e7c7f6ca0e59052f2bb29f8179313510977377

Hash: c2679f9

Mono 3.2.6 ((no/9b58377)

Xam.Android 4.13.0-36 (mac master)
Comment 5 ilya.golovach 2014-05-11 14:09:49 UTC
I can confirm this issue too. Did not have it previously (used Xamarin iOS maybe half a year ago). However, it appeared after upgrading to latest version today.
Comment 6 Adam Hartley [MSFT] 2017-07-21 09:37:46 UTC
Thanks so much for taking the time to submit this report! I attempted to reproduce this issue based on the bug description with the latest Visual Studio 2017 for Mac Preview version 7.1, and I was unable to hit the problem. If this issue is still occurring for you, please reopen this report.