Bug 14047 - UICollectionView works in IPhone Simulator but crashes in device
Summary: UICollectionView works in IPhone Simulator but crashes in device
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 6.4.0
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2013-08-16 16:51 UTC by overgaardmorten
Modified: 2013-12-05 18:34 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Sample project showing bug (144.28 KB, application/zip)
2013-08-16 16:51 UTC, overgaardmorten

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description overgaardmorten 2013-08-16 16:51:31 UTC
Created attachment 4653 [details]
Sample project showing bug

Cannot get UICollection to View when running in device. Works as expected in Simulator
Attached is sample project.

Steps to reproduce.

1)Swipe left to get to menu
2) Select "Players" item --> Crash

I have tried tons of things to get this to work - without any luck

Any help is appreciated..

Regards Morten
Comment 1 overgaardmorten 2013-08-17 09:58:29 UTC
This seems to be a debugger issue.

The following steps solved the issue for me

just tried without debugging and it seems to work.

Here are the steps:

1) Started with a "Clean solution"
2) Switched to Release Mode
3) Run --> Start without debugging

And it works....

Regards Morten
Comment 2 Rolf Bjarne Kvinge [MSFT] 2013-08-19 08:01:29 UTC
Can you get the complete version information from Xamarin Studio (About -> Show Details) and also any crash reports and application output?
Comment 3 PJ 2013-11-19 17:04:37 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 4 PJ 2013-12-05 18:34:45 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.