Bug 1400 - Mono-sgen --with-large-heap fails with program, worked fine in 2.8.2
Summary: Mono-sgen --with-large-heap fails with program, worked fine in 2.8.2
Alias: None
Product: Runtime
Classification: Mono
Component: GC ()
Version: unspecified
Hardware: PC Linux
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2011-10-10 14:33 UTC by Matt Newman
Modified: 2014-01-12 01:34 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Error log (40.84 KB, application/octet-stream)
2011-10-10 14:33 UTC, Matt Newman

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Matt Newman 2011-10-10 14:33:42 UTC
Created attachment 663 [details]
Error log

We use mono-sgen with a software that takes a large amount of memory (usually 6-8gb per run).  In mono 2.8.1 and 2.8.2, mono-sgen is able to easily complete this process. However, in the latest versions of mono (including from the daily builds), this does not work, and we seem to ?randomly? generate errors.  It seems to be related to threading.
Comment 1 Rodrigo Kumpera 2011-11-07 16:43:45 UTC
Please provide more details about your environment and a test case that shows your problem as the crash log is not enough to figure out what's wrong.

Optionally, you can enable coredumps and provide us with one.
Comment 2 Marius Ungureanu 2013-11-23 05:15:49 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days.
Can we put this back into the NEW or CONFIRMED state, or are we still awaiting

If there is no change in the status of this bug over the next two weeks, this
bug will be marked as NORESPONSE.
Comment 3 Rodrigo Kumpera 2014-01-12 01:34:25 UTC
No further information was provided. This is sgen on mono 2.8, which is ancient, the bug has probably been fixed.