Bug 13948 - Mac Sample 'Hello_Mac' does not launch when user debug the sample after selecting Code Signing option.
Summary: Mac Sample 'Hello_Mac' does not launch when user debug the sample after selec...
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Samples ()
Version: 1.4.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Vincent Dondain [MSFT]
Depends on:
Reported: 2013-08-13 07:17 UTC by Saurabh
Modified: 2014-12-19 18:51 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Saurabh 2013-08-13 07:17:08 UTC
Steps to reproduce this issue:
1. Open Mac Sample 'Hello_Mac'.
2. Open Project option select 'Mac OSX Packaging'.
3. Check 'Sign the application bundle' under 'Code Signing Option'.
4. Debug the application.

Actual Result: When user debug the application, Application icon display in Dock but application does not launch and gets terminate. While in release mode it is diving error this is the gist for the same: https://gist.github.com/saurabh360/221d2fd741248f696d3b

Note: This is working fine for other applications.

Expected Result: Application 'Hello_Mac' should launch after selecting Code Signing option.

Supplement info:

Environment details:
All Mac
X.S 4.0.11(build 7)
Mono 3.2.1-1
X.Mac 1.6.9

Regression Status:
Same behavior happening with X.Ma 1.4.22. we are not sure this has ever worked or not
Comment 1 Vincent Dondain [MSFT] 2014-12-19 18:51:17 UTC
I just tried to reproduce this bug following carefully your instruction and everything is working fine for me.

This that bug was filled more than a year ago there is obviously here a big chance that someone fixed that.

For now I'm resolving this issue as fixed but feel free to reopen it if needed.


--- Xamarin Studio ---
Version 5.7 (build 660)
Installation UUID: 145b5200-de94-4a06-b034-848d653982c3
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

--- Apple Developer Tools ---
Xcode 6.2 (6753)
Build 6C101

--- Xamarin.iOS ---
Version: (Business Edition)
Hash: 2c57f4e
Build date: 2014-12-18 16:42:49-0500

--- Xamarin.Android ---
Version: (Business Edition)
Android SDK: /Users/Vince/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0.3  (API level 15)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_20-ea"
Java(TM) SE Runtime Environment (build 1.8.0_20-ea-b23)
Java HotSpot(TM) 64-Bit Server VM (build 25.20-b22, mixed mode)

--- Xamarin.Mac ---
Version: (Business Edition)

--- Build Information ---
Release ID: 507000660
Git revision: 6a74f9bdb90d9415b597064d815c9be38b401fee
Build date: 2014-12-18 00:38:00-05
Xamarin addins: 57be0f5e1433cb58b70ea9b52e9dc77ad791be40

--- Operating System ---
Mac OS X 10.10.1
Darwin iMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64