Bug 139 - [VS] Cannot run additional projects added to a solution
Summary: [VS] Cannot run additional projects added to a solution
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 1.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2011-08-01 19:34 UTC by Slava
Modified: 2011-11-20 17:53 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

My Monodroid project file (3.69 KB, text/xml)
2011-08-04 01:17 UTC, Slava
Craig's Monodroid project file (3.81 KB, text/xml)
2011-08-04 01:17 UTC, Slava

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Slava 2011-08-01 19:34:59 UTC
I have a working monodroid solution with a project created from Visual Studio 2010.

I add another existing Monodroid project to copy code etc.

When I switch to make it a startup project, "Debug" button gets disabled and I cannot start the added project.

If I switch back to the first project I can start it (button gets enabled).
Comment 1 Jonathan Pobst 2011-08-02 12:04:53 UTC
Does the second MonoDroid project have this in the .csproj?


This is what it should be looking for.

If it does and this still doesn't work, can you attach a solution that reproduces this issue?  I tried following your steps and it seems to work as expected.
Comment 2 Slava 2011-08-04 01:15:32 UTC
Thanks Jonathan
You are right - this line does not exist in these projects.
Even in the projects created by me!
Very strange...
Different version maybe?
Please see attached - OzQuake is my project and RestGuide is Craig Dunn's project I downloaded from GitHub.
Comment 3 Slava 2011-08-04 01:17:01 UTC
Created attachment 61 [details]
My Monodroid project file
Comment 4 Slava 2011-08-04 01:17:26 UTC
Created attachment 62 [details]
Craig's Monodroid project file
Comment 5 Jonathan Pobst 2011-08-06 11:58:27 UTC
Example attached, removing NEEDINFO status.
Comment 6 Jonathan Pobst 2011-08-17 10:31:31 UTC
I tried downloading RestGuide and adding it to a solution that just had the default template application.  I set it as the startup project and it worked as expected.

You do bring up a good point about versions.  If the project was created in 2010, it would not have the <AndroidApplication> element.  This was added in December 2010.
Comment 7 Jonathan Pobst 2011-11-20 17:53:50 UTC
Cannot reproduce, may be caused by really old project files.