Bug 13747 - [Tab 7''] Getting exception "OpenTK.Platform.Android.EglException" when application 'GLDiagnostics' deployed to device.
Summary: [Tab 7''] Getting exception "OpenTK.Platform.Android.EglException" when appl...
Alias: None
Product: Android
Classification: Xamarin
Component: Samples ()
Version: 4.8.x
Hardware: PC Mac OS
: Low normal
Target Milestone: ---
Assignee: John Pilczak
Depends on:
Reported: 2013-08-05 07:52 UTC by narayanp
Modified: 2014-07-15 12:06 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description narayanp 2013-08-05 07:52:45 UTC
Steps to reproduce this issue:
1. Open Android application "GLDiagnostics".
2. Debug or run the application on physical device(Samsung Tab 7" Version 2.2).

Actual Result: Application deployed to device but does not launch and throwing exception"OpenTK.Platform.Android.EglException" on Samsung Tab 7" Version 2.2 while on 2.2 emulator it is working fine even on other devices it is working fine.

Expected Result: Application should launch on Samsung Tab 7" Version 2.2.

Supplement info:
Application Output: https://gist.github.com/saurabh360/d4c8f10df204fb1431a4
Logcat: https://gist.github.com/saurabh360/f2a12d50a08f8f1f2ef2

Environment details:
All Mac
X.S 4.0.11(build 6)
Mono 3.2.1
Xamarin.Android 4.8.2

Device info:
Samsung Tab 7" Version 2.2

Regression Status:
Same error getting with Stable 4.6.8 we are not sure weather this has worked on previous builds or not.
Comment 1 Peter Collins 2013-08-22 15:35:21 UTC
I was unable to reproduce this issue with a few devices, including a Samsung Replenish v2.2.2

Unfortunately we no longer have a Samsung Tab 7" v2.2 in the Cambridge office, so I am unable to reproduce the exact conditions this was filed against.
Comment 2 narayanp 2013-09-12 09:45:22 UTC
Today I have checked this issue with following builds:

All Mac
X.S 4.1.10(build 15)
Mono 3.2.3
X.Android 4.8.2-57

We are still getting same exception on Samsung Tab7(2.2). This is the logs for the same:
Android Logcat: https://gist.github.com/saurabh360/42a3b16e7d9a5f57d0a2
Application Output:  https://gist.github.com/saurabh360/6bd025eab1eccb9ce268
Comment 3 John Pilczak 2014-06-27 13:57:33 UTC
I have just tested this on the Samsung Tab(2.2) and was unable to reproduce this issue in the current version. Is this issue still occurring for you on this device?

App Output: https://gist.github.com/JohnPilczak/6923d78c60ed61528765

Environment Info:
=== Xamarin Studio ===

Version 5.0.1 (build 3)
Installation UUID: ea2dde6b-0915-4e87-bf59-0163cddeada5
	Mono 3.4.0 ((no/954ed3c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 304000214

=== Xamarin.Android ===

Version: 4.12.5 (Trial Edition)
Android SDK: /Users/johnpilczak/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		1.6   (API level 4)
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.Mac ===


=== Build Information ===

Release ID: 500010003
Git revision: f94ee866936d25105704eb63728ad5a981eda0a4
Build date: 2014-06-04 12:19:12-04
Xamarin addins: 1a6044e8321ea07e03a56b5381951686c82fed8b

=== Operating System ===

Mac OS X 10.9.2
Darwin Vinces-xMac.local 13.1.0 Darwin Kernel Version 13.1.0
    Thu Jan 16 19:40:37 PST 2014
    root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
Comment 4 Akhilesh kumar 2014-07-15 12:06:39 UTC
I have checked this issue with Samsung Tab7(Android 2.2), now I am also not able to reproduce this issue at our end. On running "GLDiagnostics" android application on Samsung Tab7(Android 2.2), application does not throw any exception.

X.Android 4.14.0-51

Samsung Tab7(Android 2.2)

App info: monodroid-samplesb20c93af2e7d3555c679f961798fc172ae91bebb/GLDiagnostics

If I will get this issue again in future, I will file a new bug for the same.

As of now I am closing this issue.