Bug 13655 - [Windows] Running devices do not appear in "Manage Devices" (depending on Java version?)
Summary: [Windows] Running devices do not appear in "Manage Devices" (depending on Ja...
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Greg Munn
Depends on:
Reported: 2013-07-31 12:19 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2016-08-03 15:37 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Brendan Zagaeski (Xamarin Team, assistant) 2013-07-31 12:19:52 UTC
From the forums (http://forums.xamarin.com/discussion/6533/xamarin-cannot-see-running-avds):

In Xamarin, I hit the run button and after the project is finished building, I get a dialog to select a device. There are a list of emulators available, so I click one and hit start emulator. The emulator then successfully starts. But Xamarin still claims the device is "not started", and refuses to allow me to deploy.

The emulator is working, and Eclipse has no problem deploying to it. I've tried attaching a real device (4.2 and 4.3), and Xamarin detects neither, whereas Eclipse will happily deploy to it.

I have pressed the refresh button more than a thirsty man in front of some kind of slushie machine. Sadly, no effect.

I ran adb devices, it does have the avd that's currently running listed. For completeness, I killed and restarted the server as well. Still no joy.

I have run a variety of emulators, from 2.3 up to 4.3. Mostly I've been running 4.2, but nothing has worked on Xamarin.

My Java version is 7 as it turns out. 1.7.0_25, or something to that effect. However, I'm pretty sure I also have 6 installed, and that's what Android & Xamarin is using (see below, under Xamarin version). 

=== Xamarin Studio ===
Version 4.0.10 (build 7)
Installation UUID: 7fcef020-62ca-4992-9e6f-806255a576d8
Microsoft .NET 4.0.30319.18052
GTK 2.24.13
GTK# (

=== Xamarin.Android ===
Version: 4.8.0 (Starter Edition)
Android SDK: C:\Program Files (x86)\Android\android-sdk
Supported Android versions:
    2.1   (API level 7)
    2.2   (API level 8)
    2.3   (API level 10)
    3.1   (API level 12)
    4.0   (API level 14)
    4.0.3 (API level 15)
    4.2   (API level 17)

Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_32
java version "1.6.0_32"
Java(TM) SE Runtime Environment (build 1.6.0_32-b05)
Java HotSpot(TM) Client VM (build 20.7-b02, mixed mode, sharing)

=== Build Information ===
Release ID: 400100007
Build date: 2013-07-20 02:59:47Z
Xamarin addins: fe4f180e2386eafc00087ef68c3a580cff4a2592

=== Operating System ===
Windows 6.1.7601.65536 (64-bit)
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2013-08-01 02:33:57 UTC
The problem might not to be as easily reproducible as I had hoped. I could not reproduce it with any combination of Java 1.60_39 and 1.70_25.
Comment 3 Greg Munn 2015-03-11 16:09:05 UTC
Judging from the age of this report and no further updates, I'll close the bug off for now.