Bug 13486 - SSL error on 4.3 that previously worked
Summary: SSL error on 4.3 that previously worked
Status: RESOLVED DUPLICATE of bug 6510
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries ()
Version: 4.8.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2013-07-25 16:28 UTC by Jérémie Laval
Modified: 2013-07-25 16:38 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Jérémie Laval 2013-07-25 16:28:46 UTC
Stacktrace: https://gist.github.com/garuma/dcde2970a9d7eab68337

The website used: https://thehubway.com/

Basically a SSL certificate that used to be supported seems to be not be anymore with Android 4.3 (afaict).

@Sebastien: does the exception make sense to you (notably the PKIX mention)?
Comment 1 Jonathan Pryor 2013-07-25 16:38:01 UTC
This is probably a dupe of:


This is the important part of your stacktrace:

> 07-25 15:15:47.154: E/RentalsGenericError(3779): Caused by: java.security.NoSuchAlgorithmException: CertificateFactory PKIX implementation not found

What's happening is that prior to XA 4.8 we'd try to load the wrong CertificateFactory, and you're not using XA 4.8. (Nor can you, because of Bug #13460.)

*** This bug has been marked as a duplicate of bug 6510 ***