Bug 13455 - Not able to install F# Mpack on Windows
Summary: Not able to install F# Mpack on Windows
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: 4.1
Hardware: PC Windows
: High critical
Target Milestone: 4.0.13 (XCode5)
Assignee: Mikayla Hutchinson [MSFT]
Depends on:
Reported: 2013-07-25 02:36 UTC by Prashant manu
Modified: 2013-09-20 13:37 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Prashant manu 2013-07-25 02:36:41 UTC
Steps to Reproduce:
1. Download latest mpack F# language binding from URL [http://addins.monodevelop.com/Project/Index/48]
2. Open XS on windows (32 or 64 bit)
3. Open Add in manager.
4. Click button 'Install from file'
5. Browse and Install F# mpack for windows.

Actual Result:
'Installation failed' error message shown when user tries to install F# language binding on windows which is mentioned in screencast: http://screencast.com/t/9LOVZLLP9Fyg

Expected Result:
User should be able to install F# language binding successfully on windows.

All windows
XS 4.1.8(build 1)

Regression Status:
REGRESSION: We are able to install it using X.S 4.0.10(build 7)
Comment 2 Alan McGovern 2013-07-25 14:06:34 UTC
This is our regression, should be easy to fix. We just have to update the Exclude list in Mono.Addins.
Comment 3 Alan McGovern 2013-07-25 14:33:15 UTC
Fixed and cherry-picked to the branch.
Comment 4 Alan McGovern 2013-07-25 14:33:30 UTC
Fixed and cherry-picked to the branch.
Comment 5 narayanp 2013-07-26 02:51:21 UTC
Today we have checked this issue with following builds:

All Windows
X.S 4.1.8(build 5)
X.Android 4.8.0-13

We are still not able to install F# and getting same error. This is the screencast for the same: http://screencast.com/t/alCMRvCldR

Hence, Reopening this issue.
Comment 6 Alan McGovern 2013-07-26 03:16:18 UTC
Can you open the 'About Xamarin Studio' window, click on 'Show Details' and look in the 'Build Information' section. It should say that the Git revision is '546c3001d0aaffd50d1bc013451089fd431a8a42'. Is this the case?
Comment 7 narayanp 2013-07-26 04:59:31 UTC
=== Xamarin Studio ===

Version 4.1.8 (build 5)

Installation UUID: 1a4f208c-e41a-4374-916d-8e86d606fb42


	Microsoft .NET 4.0.30319.18046

	GTK 2.24.13

	GTK# (

=== Xamarin.Android ===

Version: 4.8.0

Android SDK: C:\Users\Administrator\AppData\Local\Xamarin\MonoForAndroid\AndroidSDK

	Supported Android versions:

		2.1   (API level 7)

		2.2   (API level 8)

		2.3   (API level 10)

		3.1   (API level 12)

		3.2   (API level 13)

		4.0   (API level 14)

		4.0.3 (API level 15)

		4.1   (API level 16)

		4.2   (API level 17)

Java SDK: C:\Program Files\Java\jdk1.6.0_31

java version "1.6.0_31"

Java(TM) SE Runtime Environment (build 1.6.0_31-b05)

Java HotSpot(TM) Client VM (build 20.6-b01, mixed mode, sharing)

=== Build Information ===

Release ID: 401080005


Build date: 2013-07-25 15:34:22Z

Xamarin addins: 65c34a7d3e5e239a6270734df7bed2f65ec41575

=== Operating System ===

Windows 6.2.9200.0
Comment 8 Alan McGovern 2013-07-29 17:49:21 UTC
This should be fixed with the latest builds from the 4.1.8 branch and also master branch. I'll close this, but please do reopen if you can still reproduce the issue.
Comment 9 Prashant manu 2013-07-31 03:36:00 UTC
Today we have checked this issue with following builds:

All Windows
X.S 4.1.8(build 8)
Build Information
Release ID: 401080008

X.Android 4.8.1-10

We are able to install F# but not able to install F# support for Xam.Android. In Add in manager gallery it is not shown and refreshing Gallery gives error.

Error information: https://gist.github.com/saurabh360/aabd4af1eeafdfef2f3a

This is the screencast for the same: http://screencast.com/t/K0hCaaWzFX

Hence, Reopening this issue.
Comment 10 Nischal 2013-07-31 04:24:39 UTC
We have checked this with latest build of X.S 4.0.11(build 4) and experiencing the same issue as mentioned in Comment 9

All Windows
X.S 4.0.11(build 4)
Comment 11 Alan McGovern 2013-07-31 08:29:29 UTC
That second issue is expected because the build has not been fully published on the live server. The Adding Repositories are only set up when that happens so the only way to test addins is by manually installing mpacks as you successfully did.
Comment 12 PJ 2013-08-09 15:20:03 UTC
This regressed in XS 4.0.12 due to the casing of the file on a different build machine. Users on windows are currently seeing http://screencast.com/t/PPCfAfXM when they try to install an addin.

Alan has committed another few casings to try and catch them all, but the real fix is to accept all casings and/or unit test the version created by the build bot. Here's his commit: http://git.io/2O6CnQ

I've filed bug 13893 to cover the testability of the feature in general. This will remain to track actually getting a build that has this fixed on the stable channel ASAP.
Comment 13 Saurabh 2013-09-20 13:37:15 UTC
Today, I have checked this issue with XS 4.0.13(Build 37) on Windows 7 and 8.

I have tried to add 'MonoDevelop.FSharpBinding-3.2.15.mpack' through Add-in Manager and I am able to install F# Language Binding successfully.

Hence closing this issue.