Bug 13429 - no response after /usr/bin/login removal
Summary: no response after /usr/bin/login removal
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 4.0.9
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Jeffrey Stedfast
Depends on:
Reported: 2013-07-24 05:17 UTC by feifan1988
Modified: 2013-07-24 21:06 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description feifan1988 2013-07-24 05:17:44 UTC
Xamarin Studio worked great until I removed /usr/bin/login at some stage. When I try to run a console program with C#, the terminal jumps out, with nothing except the prompt only. I kill the program and run it again and get the same thing. I removed the application, restored the login file, and reinstalled the app, but get things like 
"login(1209,0x7fff7b9ce180) malloc: *** error for object 0x7fb9ab0006f0: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug"
What shall I do now?
Comment 1 Jeffrey Stedfast 2013-07-24 11:09:13 UTC
Reinstall /usr/bin/login if you want to run in an external terminal or disable running on an external console in your Project Options.
Comment 2 feifan1988 2013-07-24 21:06:08 UTC
I disabled the external console option, and it works now, thanks!