Bug 13325 - Invalid workflow displays downgrade to starter option
Summary: Invalid workflow displays downgrade to starter option
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Activation ()
Version: 1.3.x
Hardware: PC Windows
: Low normal
Target Milestone: 1.6.x (connection)
Assignee: Dominique Louis
Depends on:
Reported: 2013-07-18 16:32 UTC by Peter Collins
Modified: 2013-11-15 05:03 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Peter Collins 2013-07-18 16:32:56 UTC

Comment 1 Peter Collins 2013-07-18 16:36:04 UTC
User is offered the "Use Starter Edition" option when opening a project with an invalid license on disk:

Steps to reproduce:
1) Ensure invalid license is in place (IE: touch c:\ProgramData\MonoTouch\License\monotouch.licx)
2) Open VS, create a new iOS project.
3) Invalid workflow dialog displays "Use Starter Edition" option.

Environment Details:
VS2010, VS2012
X.A 4.8.0-9 (bc182ac2)
X.I. VS 1.3.246 (9e3221fb)
Comment 2 Bo Pang 2013-10-04 16:47:00 UTC
I tested this issue using MTVS 1.6.53 and I cannot reproduce it.
Screenshot: http://screencast.com/t/94nc6yj3VUpA

Win7 x64
MTVS 1.6.53

Can you try again on the latest version?
Comment 3 Peter Collins 2013-10-04 16:55:01 UTC
I'm still seeing this on 1.6.53 (c3eac7b8):

Bo are you sure you have only an invalid license on disk, and nothing else? That dialog is showing the expired trial workflow, which would also be wrong in the case of an invalid license. Also make sure you are logged into the IDE with an account that has no expired or valid licenses.
Comment 4 Bo Pang 2013-10-04 17:31:32 UTC
Sorry I misunderstand the invalid license. I am using an expired trial license so the dialog is showing the expired trial workflow.

We still have this issue in MTVS 1.6.53

To reproduce this issue, you also need to login the IDE with an account without any licenses, expired or active.
Comment 5 Dominique Louis 2013-10-06 10:53:47 UTC
  Could you please post details of an account I can use to reproduce this so I can determine if this is something the VS team can change or I need to ask the activation team to do it,
Comment 6 Bo Pang 2013-10-06 14:12:20 UTC
(In reply to comment #5)
> @BoPang,
>   Could you please post details of an account I can use to reproduce this so I
> can determine if this is something the VS team can change or I need to ask the
> activation team to do it,

Here is the account information:

Email: newaccount@xamarin.com
Password: xamarin

Or you can just create a new account.
Comment 7 Dominique Louis 2013-10-07 11:15:24 UTC
Hi Peter, BoPang,
  I'm not able to repro this at all. I've even tried being logged out of my account and deleting all licenses and still not saying any indication of Starter anywhere. I'll ask others on the team to try to repro.

Comment 8 Bo Pang 2013-10-07 17:20:46 UTC
Hi Dominique,

To repro this issue, you need login with a new account without beginning trail or have other license.

Here is the step to repro:

1. Delete all license in c:\ProgramData\MonoTouch\License\
2. Create a invalid license in c:\ProgramData\MonoTouch\License\ by adding a new empty file named monotouch.licx 
3. Open Visual Studio 2012, create a new account and login with it.
4. Create a new iOS project.
Comment 9 Dominique Louis 2013-10-08 13:20:58 UTC
Thanks for the repro steps Bo Pang.
The fix for this should be part of this build
When wrench gets round to actually building it.
Comment 10 PJ 2013-10-16 12:21:54 UTC
Based on comment 9, marking as RESOLVED FIXED
Comment 11 Mohit Kheterpal 2013-11-15 05:03:53 UTC
Today we have checked this issue and follow steps mention in comment 8, but now when we put invalid license on disk & open VS and login with an activated account then invalid license is replaced with current active account. Now the functionality changes, so unable to reproduce this issue any more.

VS 2013
MTVS 1.8.365

Hence closing this issue.