Bug 13252 - GTK# 2.12.21 not updating
Summary: GTK# 2.12.21 not updating
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Updater ()
Version: 4.0.9
Hardware: PC Windows
: --- normal
Target Milestone: master
Assignee: Duncan Mak
Depends on:
Reported: 2013-07-15 11:22 UTC by Brian Bourke-Martin
Modified: 2017-03-24 20:15 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Log from Case #45584 (35.35 KB, text/plain)
2013-09-11 11:31 UTC, Allie Miller

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Brian Bourke-Martin 2013-07-15 11:22:16 UTC
Description of Problem:
When attempting to update GtkSharp from the Help->Check for Updates the item appears to download but fails to install.

Steps to reproduce the problem:
1. Go to the updater in Help->Check for Updates (stable channel) after having installed GtkSharp 2.12.20
2. Attempt to update to 2.12.21

Actual Results:
The installer open and closes quite quickly presumably due to an unreported error.

Expected Results:
Updating GtkSharp to 2.12.21

How often does this happen? 
Every time

Additional Information:
I have tried to perform the update by manually installing the package, but the latest package on the mono website is still 2.12.20
Comment 1 Mikayla Hutchinson [MSFT] 2013-07-15 16:42:51 UTC
Can you please find the failure reason in the Windows Error Log?
Comment 2 Brian Bourke-Martin 2013-07-15 16:51:20 UTC
I looked in the logs to see that the package was installed correctly and confirmed this in the control panel.  So the issue seems to be more that Xamarin Studio still thinks that the package need to updated for some reason and is trying to install an already installed package.
Comment 3 Brian Bourke-Martin 2013-07-16 09:53:49 UTC
I also just looked at the Help->About->Details box and found the following information in Xamarian Studio.

Xamarin Studio
Version 4.0.9 (build 12)
Installation UUID: d03c4f6d-c3bf-4682-a921-ea484b2d6d2b
	Microsoft .NET 4.0.30319.18052
	GTK 2.24.13
	GTK# (

Not Installed

Build Information
Release ID: 400090012
Build date: 2013-06-21 14:03:10Z
Xamarin addins: 898d8afaabb160c025e21656f1490fa149397bff

Operating System
Windows 6.1.7601.65536 (64-bit)
Comment 4 Duncan Mak 2013-07-16 10:19:31 UTC
The website has been updated to link to 2.12.21 (our current stable) MSI.

You might also want to try the beta installer for 2.12.22, the URL is http://download.xamarin.com/GTKforWindows/Windows/gtk-sharp-2.12.22.msi
Comment 5 Brian Bourke-Martin 2013-07-16 10:30:59 UTC
Updated to 2.12.22 and it seems to have resolved the issue.
Comment 6 Peter Hultqvist 2013-08-26 08:31:57 UTC
I'm running the Xamarin Studio Stable channel and it is currently stuck at GtkSharp 2.12.20, it keeps informing me over and over again that 2.12.22 is downloaded and ready to install but after the update the same update message appears again.

I tried to run the gtk-sharp linked above manually where I got the option to Repair or Remove, running repair gave an error which also was found in the error logs:

Product: Gtk# for .Net 2.12.22 -- Error 1316. A network error occurred while attempting to read from the file: C:\Users\peter\Downloads\600D9C0E-3B74-4C51-B7E6-29A47E9325E4-2012022.msi

The upgrade using XamarinStudio gives the following entires
En Windows Installer-transaktion påbörjas: C:\Users\peter\AppData\Local\XamarinStudio-4.0\Cache\TempDownload\600D9C0E-3B74-4C51-B7E6-29A47E9325E4-2012022.msi. Klientens process-ID: 2716.
Product: Gtk# for .Net 2.12.22 -- Configuration completed successfully.
Produkten konfigurerades om med Windows Installer. Produktnamn: Gtk# for .Net 2.12.22. Produktversion: 2.12.22. Produktspråk: 1033. Tillverkare: Xamarin, Inc.. Slutförande- eller felstatus efter omkonfigurationen: 0.
En Windows Installer-transaktion avslutas: C:\Users\peter\AppData\Local\XamarinStudio-4.0\Cache\TempDownload\600D9C0E-3B74-4C51-B7E6-29A47E9325E4-2012022.msi. Klientens process-ID: 2716.
Startar session 0 - ‎2013‎-‎08‎-‎26T12:28:42.041445000Z.
Avslutar session 0 startade ‎2013‎-‎08‎-‎26T12:28:42.041445000Z.

The last two lines are from the RestartManager and the other are from MsiInstaller.
Comment 8 Allie Miller 2013-09-11 11:31:28 UTC
Created attachment 4837 [details]
Log from Case #45584
Comment 9 Jeffrey Stedfast 2016-10-25 21:08:41 UTC
Has anyone else seen this in more recent versions?
Comment 10 Greg Munn 2017-03-24 20:15:01 UTC
Closing. If this is still an issue, please reopen the bug. Thanks.