Bug 13198 - [iOS Device-Release mode only]Getting MT000 error when run the application using MTVS on physical device
Summary: [iOS Device-Release mode only]Getting MT000 error when run the application us...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.3.x
Hardware: PC Windows
: High blocker
Target Milestone: 1.3.x
Assignee: Vinicius Jarina
Depends on:
Reported: 2013-07-12 03:42 UTC by narayanp
Modified: 2013-07-15 14:06 UTC (History)
7 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description narayanp 2013-07-12 03:42:09 UTC
Steps to reproduce this issue:
1. Open or create iOS application in VS
2. Connect to Build Host.
3. Select configuration as Release and Platform as iPhone.
4. Run the application.

Actual Result: Application deployed to device on build host but does not launch and error displayed in VS "Error	1MT0000:Unexpected error - Please file a bug report at http://bugzilla.xamarin.com [c:\users\administrator\documents\visual studio 2012\Projects\HelloWorld_App7\HelloWorld_App7.csproj". While this is working fine on Simulator.

Expected Result: Application should deployed and launched on iOS device in release mode.

Supplement info:
Error on VS: https://gist.github.com/atin360/371cd60f3e2b9815d5f2
Debug log: https://gist.github.com/atin360/7a76bcfe421117b1b78c
Mac Server Log: https://gist.github.com/atin360/853403df3879c777ed23
MTBServer Log: https://gist.github.com/atin360/e5cfc3212b6201fccf6c
Application Log: https://gist.github.com/atin360/cebd10342144ee41eecb

Environment details:
All Windows
VS 2012/2010
Xamarin.iOS 6.3.8-5
iOS for VS 1.3.223

Regression Status:
REGRESSION: This is working fine with stable Xamarin.iOS
Comment 1 PJ 2013-07-12 12:04:00 UTC
Ok so wait, does this mean you guys are no longer seeing 13187 on this build?
Comment 2 PJ 2013-07-12 14:37:29 UTC
Vinicius, did you say you couldn't reproduce? I just tried with only 1.3.225 installed and it worked for me on a basic Hello World Application

I'm connected to on the Mac.

I'll try to reproduce after installing the android RC.
Comment 3 PJ 2013-07-12 15:17:15 UTC
Can't reproduce after 4.8 installing 4.8.0001 either, I'll run the case again using the upgrade path from the current stables.
Comment 4 PJ 2013-07-12 15:38:59 UTC
I casually mentioned version numbers here without giving the products, and that was potentially confusing, so let me clarify that 1.3.225 was the MTVS version, was the monotouch version installed on the mac, and is the version of MFA I installed after.
Comment 5 PJ 2013-07-12 20:46:58 UTC
I am not sure if anybody can reproduce this issue. Jarina set it to IN_PROGRESS (Which usually means that the developer can reproduce and is working on a fix), but in IRC people said that he couldn't reproduce.

Lal, not only could I not reproduce or Jarina (supposedly), even Mohit could not reproduce later on in the day when it was just Team B left, presumably on the same machines you were experiencing this with.

I'm going to set this to NEEDINFO, cause we need more information here and we won't get any while it's IN_PROGRESS.

Does it happen continuously and persist through uninstall/re-install? How did Team B get out of this situation?
Can you deploy directly from XS on the build host when you experience this issue?
Comment 6 narayanp 2013-07-15 02:47:05 UTC
Today I have checked this issue with following builds:

All Windows
Build host is Mac Lion-10.7.4
iOS for 1.3.227
Xamarin.iOS 6.3.8-5

And we are getting the same issue when Build host is Mac lion and user try to run the application using MTVS.

Hence reopening this issue.
Comment 7 Vinicius Jarina 2013-07-15 09:46:11 UTC
 Can you create a screencast of your procedure and gist your "Mac Server Log" again? Thank you. :)
Comment 8 PJ 2013-07-15 14:03:47 UTC
So we need to get the granularity of the configuration options to be even finer here, as this issue seems to be due to Xcode version. I'll make sure that we're taking all the mac variables into consideration when testing and reporting bugs against MTVS in the future. Mohit will be updating this bug shortly, but the look of it is that this is only for Xcodes before 4.5, and not a regression.
Comment 9 Mohit Kheterpal 2013-07-15 14:06:32 UTC
An update to the above issue:

This issue exist due to Xcode 4.4.1.
While with Xcode 4.3.3, 4.5 and 4.6.2 is working fine.