Bug 13126 - Can't deploy from VS
Summary: Can't deploy from VS
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.2.x
Hardware: PC Windows
: Normal major
Target Milestone: ---
Assignee: Vinicius Jarina
Depends on:
Reported: 2013-07-09 11:23 UTC by Goncalo Oliveira
Modified: 2013-07-10 17:29 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Goncalo Oliveira 2013-07-09 11:23:58 UTC
[2013-07-09 16:07:09.9] 	Embedding provisioning profile
[2013-07-09 16:07:09.9] 	Processing entitlements file
[2013-07-09 16:07:09.9] 	Preparing resources rules
[2013-07-09 16:07:09.9] 	Signing application
[2013-07-09 16:07:11.4] [...]/FrotcomMobileApp.app: signed bundle with Mach-O thin (armv7) [frotcom.app.iphone]
[2013-07-09 16:07:11.4] Command [Build: CommmandUrl=Build] finished (9)
[2013-07-09 16:07:11.5] Starting /Developer/MonoTouch/usr/bin/mtouch -sdkroot "/Applications/Xcode.app/Contents/Developer" --entitlements
[2013-07-09 16:07:12.3] stdout: 784[...] MonoTouch Business 2014-03-13T17:29:45
[2013-07-09 16:07:12.3] 
[2013-07-09 16:07:12.3] Handling with command: [Deploy: CommmandUrl=Deploy] (12)
[2013-07-09 16:07:12.3] Attempting to acquire command execution lock, timeout set to 00:10:00
[2013-07-09 16:07:12.4] Starting /Developer/MonoTouch/usr/bin/mtouch -sdkroot "/Applications/Xcode.app/Contents/Developer" --devname "[...] iPhone" --installdev "[...]/Library/Caches/Xamarin/mtbs/builds/[...]/output/Debug/iPhone/FrotcomMobileApp.app"
[2013-07-09 16:07:23.1] stderr: Installation failed: Your code signing/provisioning profiles are not correctly configured (error: 0xe8008016)

Double checked project settings for identity and profile. Double checked info.plist for any entitlements. Everything is correct.
If I send the project to my mac and open with XS, builds and deploys correctly.

Already manually compared two project and info.plist, they are identical. the identity and profile are correct and valid for the device in question. I am using explicit identity and profile, though, also tried with automatic and explicit wildcards. Same result.

Initially had this problem on 1.1.200, upgraded to beta 1.2.121 with the same results.

This is extremely frustrating and is not allowing me to do my job correctly, so a critical issue to me.
Comment 3 Vinicius Jarina 2013-07-09 13:25:54 UTC
Hi Goncalo.

What is you monotouch version?

   /Developer/MonoTouch/usr/bin/mtouch --version

Thank you.
Comment 4 Goncalo Oliveira 2013-07-10 04:24:09 UTC (947e664)
Comment 5 Vinicius Jarina 2013-07-10 14:03:47 UTC
Hi Goncalo

What command are you doing from VS?

Are you trying to create the IPA or just run the application on the device?

Can you create a screencast of your procedure?

Thank you.