Bug 13072 - http://iosapi.xamarin.com/ directs searches to http://xamarin.alley.ws/ and hangs
Summary: http://iosapi.xamarin.com/ directs searches to http://xamarin.alley.ws/ and h...
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Documentation ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
Depends on:
Reported: 2013-07-05 13:51 UTC by Andrew Fernandes
Modified: 2014-02-25 12:20 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Andrew Fernandes 2013-07-05 13:51:46 UTC
Description of Problem:

When searching the xamarin docs from http://iosapi.xamarin.com/, hitting "more options" redirects the search to an "alley.ws" domain and hangs. This makes searching on the docs site broken.

Steps to reproduce the problem:
1. open a fresh browser (clear cookies, caches, etc.)
2. navigate to iosapi.xamarin.com
3. use the search box in the upper right to search for, for example, "AudioUnitStatus"
4. watch the search update in real time (goodness!)
5. click on "More results..."

Actual Results:

The browser will direct the search to "http://xamarin.alley.ws/search?kw=AudioUnitStatus", clearly not a xamarin domain. (http://alley.ws/ appears to be the personal homepage of one Austin Smith, whoever that is...). The search hangs.

Expected Results:

Searching the documentation, as worked many times previously. :-)

How often does this happen? 


Additional Information:

Tried on several different browsers, cleared cookies, caches, and proxied my connection via VPN to make sure there wasn't any IP silliness from my ISP. Nope. Seems to be the actual code on your end, AFAIK.
Comment 1 Andrew Fernandes 2014-02-25 12:20:32 UTC
Started working as expected whenever docs started using google custom search.