Bug 12921 - Tipcalc/MWC mobile samples for android giving a build error i,e -Error XA0000
Summary: Tipcalc/MWC mobile samples for android giving a build error i,e -Error XA0000
Alias: None
Product: Android
Classification: Xamarin
Component: Samples ()
Version: 4.7.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Peter Collins
Depends on:
Reported: 2013-06-27 13:46 UTC by Akhilesh kumar
Modified: 2013-06-28 13:35 UTC (History)
0 users

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Akhilesh kumar 2013-06-27 13:46:39 UTC
Steps to reproduce:
1.Open Tipcalc/MWC mobile samples for android is XS.
2.Build an application.

Actual Result:
Tipcalc/MWC mobile samples for android giving a build error i,e -Error XA0000

Expected Result:
Tipcalc/MWC mobile samples should build successfully.

Supplement Info:
Diagnostic build output:
TipCalc:  https://gist.github.com/atin360/f45cd3dae0397cfd26dd
MWC:  https://gist.github.com/atin360/246242859e004ecaf6f2

Build output:

Application Info:

Environment Info:
For All Mac
XS 4.0.9(build 12)
MFA 4.7.11-2-1

Regression Status:REGRESSION, working fine with MFA 4.7.10
Comment 1 Akhilesh kumar 2013-06-27 14:50:31 UTC
An update to the above issue:
Same error is happening for ' Tasky ' application also.
Comment 2 Peter Collins 2013-06-27 18:52:16 UTC
I'm unable to reproduce this XA9000 error on the alpha build of XA  (4.7.11). Please make sure your mobile-samples repo is a clean checkout and up to date by running the following from within the mobile-samples directory:
> git clean -xfd
> git reset --hard HEAD
> git pull 

Let me know if you are still encountering this error after following the above steps.
Comment 3 Akhilesh kumar 2013-06-28 13:35:08 UTC
Today we have checked this issue with the following builds:

For All Mac
XS 4.0.9(build 12)
MFA 4.7.11-2-1

Again tried with clean and up to date mobile-samples and we able to build and run MWC/Tasky/Tipcalc applications successfully.

Hence changing this issue status as verified.