Bug 12906 - Xamarin Studio won't start debugging XA app
Summary: Xamarin Studio won't start debugging XA app
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: 4.0.9
Hardware: PC Windows
: --- normal
Target Milestone: master
Assignee: Mikayla Hutchinson [MSFT]
Depends on:
Reported: 2013-06-26 13:14 UTC by mizzu_xfil3_virus
Modified: 2014-01-20 03:28 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

AndroidTools log + Idle log merged . (29.79 KB, text/plain)
2013-06-26 13:14 UTC, mizzu_xfil3_virus

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description mizzu_xfil3_virus 2013-06-26 13:14:03 UTC
Created attachment 4208 [details]
AndroidTools log + Idle log merged .

Up until today I had an old version of Mono for Android installed on my Win7 PC . I've used it some time ago along with Visual Studio & the emulator and everything was working fine at the time .

Today I decided to start messing around with it again . So I uninstalled M4A , downloaded Xamarin.Android (the XamarinInstaller actually , which installed everything I needed , including the ADK and all of the other stuff) . Now I was able to use M4A along with Visual Studio , but since X.A doesn't have this feature for free anymore , I tried using Xamarin Studio .

So I loaded one of my past project into Xamarin Studio (by loading the .sln file) , everything went great , the solution was properly imported , but I have one problem . The debugger does not work . The app is being deployed to the device successfully but the debugger does not start , and neither is the app on the device . It just pushes & installs it on the device but doesn't run it , and as soon as I get a "Deployment completed." message in the Deploy window , XS switches from debug view to solution view . It's the same both with the emulator and the physical device .
Comment 1 Mikayla Hutchinson [MSFT] 2013-06-26 19:56:37 UTC
From the log, I see you've deployed to the device "" and the emulator "emulator-5554". Do both of them fail?

Assuming it's just the "" that fails, I would guess that adb's port forwarding doesn't work for devices connected over tcp.
Comment 2 mizzu_xfil3_virus 2013-06-27 03:45:04 UTC
Unfortunately both of them fail the exact same way . I even tried debugging on the device via USB but it's the same .

I think the debugger is not starting or is not attaching . The application is being compiled , deployed to the device successfully , I can manually start it and it works , but the debugger just won't start . After the "Deployment completed." message I get in the "Deploy to device" pad , XS just gets back to the Solution view mode .

And yes , I have the deploy method set to Debug and NOT Release . Both of them seem to be doing the same thing anyway , except that the Release mode compiles the APK differently .
Comment 3 mizzu_xfil3_virus 2013-06-27 06:24:34 UTC
Problem solved . It wasn't because of XS , it was because of my code . It never occoured to me that I should try another app lol (I only tried with one of my old ones) . I had 2 similar functions , one in an activity & one in a service , which were kind of colliding with each other .
Comment 4 Nischal 2014-01-20 03:28:56 UTC
As per comment 3 we are considering this no more an issue. Hence marking it as Verified.