Bug 12729 - Monodevelop IDE texteditor is invisibile on KDE
Summary: Monodevelop IDE texteditor is invisibile on KDE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.0.8
Hardware: PC Linux
: Lowest normal
Target Milestone: master
Assignee: Mike Krüger
Depends on:
Reported: 2013-06-18 04:23 UTC by Francesco A.
Modified: 2013-07-12 06:14 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

An image which can explain better than me the situation. (214.37 KB, image/png)
2013-06-18 04:23 UTC, Francesco A.

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Francesco A. 2013-06-18 04:23:53 UTC
Created attachment 4139 [details]
An image which can explain better than me the situation.

I would like to report a bug i'm experiencing on KDE using Monodevelop, it's fine when I'm on gnome or Xfce. Shortly, when I'm on KDE I can't see the Monodevelop's texteditor, like you can see on the image i've attached to this post.

I tried with the Archlinux mono's version 2.10 and with a AUR package of mono 3.0.7, no changes.

Comment 1 Mike Krüger 2013-06-20 05:12:14 UTC
Which version is that ?

This should've been fixed a long time ago. Is the gtk theme used "oxygen-gtk" ? 
(Should be in the IDE options)

If so switch it to something different. If it's another theme then I need the exact theme name. But I suppose your distribution is using 4.0.0 ... which has some issues on linux.
Comment 2 Francesco A. 2013-06-20 05:51:20 UTC
Hi Mike
Yes I was using Monodevelop 4.0.* (8, exactly) and Oxygen-gtk theme.

Yes I suppose that haven't been fixed, after all
Anyways, I solved going back to Xfce but it seemed ok to report the bug existence 

Thank you
Comment 3 Mike Krüger 2013-06-20 06:35:11 UTC
ah with a big "O" ?

you don't need to go back to xfce - you can switch the gtk theme inside the monodevelop ide preferences.
Comment 4 Mike Krüger 2013-06-20 06:37:54 UTC
I now  check case insensitive - the 'fix' is just changing the theme automatically. The oxygen gtk theme has some issues with our gtk tricks we are using.

Fortunately you can manually change the gtk theme in the ide :)
Comment 5 Francesco A. 2013-07-12 06:14:26 UTC
Hi Mike
After a long time I'm heree again to tell you I found a solution on internet to solve this problem without changing oxygen theme

All you need to do is to start monodevelop with the env variable

one can put it in his ~/.profile

and everything will be fine