Bug 12651 - Unable to deploy to iOS 7 based device
Summary: Unable to deploy to iOS 7 based device
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.1.9
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
Depends on:
Reported: 2013-06-12 06:51 UTC by leigh.bowers
Modified: 2014-03-26 17:00 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description leigh.bowers 2013-06-12 06:51:43 UTC
When attempting to deploy my app to my iOS 7 based iPhone (debug and release modes), it fails with the error below.

This issue is also evident in the latest beta.


MonoTouch.MobileDevice.MobileDeviceException: Invalid Host ID Error (error: 0xe800001c)
at MonoTouch.Installation.Device.ValidatePairing () <0x0007b>
at MonoTouch.Installation.Installer/<ExecuteWithSession>c__AnonStorey15.<>m__15 (object,System.EventArgs) <0x000c7>
at MonoTouch.Installation.Device.NotificationCallback (MonoTouch.MobileDevice.am_device_notification_callback_info&) <0x00075>
at (wrapper native-to-managed) MonoTouch.Installation.Device.NotificationCallback (MonoTouch.MobileDevice.am_device_notification_callback_info&) <0x0005b>
at (wrapper managed-to-native) MonoMac.CoreFoundation.CFRunLoop.CFRunLoopRun () <0x00003>
at MonoMac.CoreFoundation.CFRunLoop.Run () <0x0000b>
at MonoTouch.Installation.Installer.ExecuteWithSession (string,MonoTouch.Installation.Installer/Executor) <0x000d7>
at MonoTouch.Installation.Installer.InstallApplicationWithoutSymbols (string,string) <0x00067>
at MonoTouch.Installation.Installer.InstallApplication (string,string,bool) <0x0002f>
at MTouch.Main2 (string[]) <0x0270f>
at MTouch.Main (string[]) <0x00017>

The application was terminated by a signal: SIGHUP
Comment 1 folex 2013-09-02 07:24:03 UTC
I have same error.
Comment 2 leigh.bowers 2013-09-04 08:37:25 UTC
This is still evident with the latest iOS 7 beta, and the Xamarin alpha builds.
Comment 3 leigh.bowers 2013-09-10 04:42:22 UTC
By re-installing the XCode 5 preview, and the latest Xamarin alphas, I got it all working. Not sure what the problem was, but this is no-longer an issue for me.
Comment 4 Danish Akhtar 2014-03-26 14:19:44 UTC
Today, we have checked this issue with:
XS 4.2.4(build 266)
ML 10.8.4

We are successfully able to deploy iOS template on iOS 7 device. Hence closing this issue
Comment 5 fredstroup 2014-03-26 16:44:35 UTC
I don't see your X.iOS available on the Xamarin alpha channel.

I am unable to deploy to an iPad recently updated to iOS 7.1 in spite I installed the latest alpha available and latest XCode as well:

Version: (Indie Edition)
Hash: 46b2486
Build date: 2014-03-24 15:04:26-0400

Build Information
Release ID: 403040000
Git revision: e2e118a56ebf05c9f15eafbf53379bdebded727c
Build date: 2014-03-12 15:39:07-04
Xamarin addins: 9f2eb9aed862e28ca23d2d2f34e22952087e6e4c

Apple Developer Tools
Xcode 5.1 (5084)
Build 5B130a

Please advise.
Comment 6 fredstroup 2014-03-26 17:00:27 UTC
Please throw away my previous comment. After a Rebuild all and accepting on the iPad to rely on my computer it worked again.