Bug 12639 - Xamarin Studio 4.1.3 hangs on OS X 10.9 Mavericks
Summary: Xamarin Studio 4.1.3 hangs on OS X 10.9 Mavericks
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.7.x
Hardware: Other Mac OS
: Highest blocker
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2013-06-11 16:22 UTC by Gerry
Modified: 2014-03-27 06:02 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Gerry 2013-06-11 16:22:56 UTC
Install OS X 10.9 from Apple on a Mac (tried on a retina Macbook Pro)

Then install from alpha or beta channel of Xamarin Studio.

Launch Xamarin Studio.
After it starts all you have to do is select "Quit" from the Xamarin Studio menu.

XS will never exit.  Open Activity Monitor.  Note that the process will typically consume 50% of the CPU with 13-15 threads, etc.
Comment 1 Bojan Rajkovic [MSFT] 2013-06-11 20:40:46 UTC
Can confirm, I believe Rodrigo is already working on it.
Comment 2 Gerry 2013-06-11 22:37:05 UTC
Ok, thanks.  I appreciate the update.
Comment 3 Rodrigo Kumpera 2013-06-11 22:38:43 UTC
Please switch to the stable channel in the meanwhile.

We're working as fast as we can to release new versions of the betas that work with Mavericks.
Comment 4 Gerry 2013-06-11 23:38:12 UTC
I unfortunately cannot switch to the stable channel since I'm using the new async/await stuff and thus need Mono 3.0.
Comment 5 Gerry 2013-06-13 00:28:28 UTC
Any kind of ETA on a fix for this?

Comment 6 Gerry 2013-06-15 09:06:10 UTC
Can someone at least comment if this fix is days or weeks out?

For now I'm running Xamarin Studio (alpha) on my Surface Pro until a fix comes out.
Comment 7 Rodrigo Kumpera 2013-06-15 12:26:02 UTC
Hi Gerry,

We have internal builds of our stack for Mavericks that are under testing. We're trying to release them next week.
Comment 8 Gerry 2013-06-17 14:39:49 UTC
Thanks-that would be great if there is a release any down now.  

The fact that I can Xamarin Studio on multiple platforms is great and my backup for now but nevertheless I look forward to running this again on my rMBP.

Comment 9 Rodrigo Kumpera 2013-06-19 11:44:19 UTC
Please use the alpha channel for now as we release support for Mavericks on it.

We'll promote the many components of our stack there to beta over the coming week.
Comment 10 Gerry 2013-06-19 11:54:54 UTC
Thanks--I just updated via the alpha channel.  (I had gone back to the stable channel for some of my project work that didn't require Mono 3.)  

So now that I'm back on the alpha channel I'm bit by this issue: http://forums.xamarin.com/discussion/3010/deployment-failed-because-of-an-internal-error-failure-install-failed-update-incompatible

The same app/code works fine from non-OSX Mavericks (e.g. Windows 8 or OSX 10.8.4).  And the app has been removed from the phone as well before trying to deploy.

I can open another bug unless this is a known issue.  Or try some other debugging to figure out if it is an issue on my side somehow.
Comment 11 Rodrigo Kumpera 2013-06-19 12:02:38 UTC
Hi Gerry, 

Reopening for further investigation by the Android team.
Comment 12 Jonathan Pryor 2013-06-19 12:28:50 UTC
@Gerry: Please see the troubleshooting page:


It's possible that your Debug signing key changed, and/or you didn't fully uninstall the app from the target.

(I have seen circumstances where uninstalling the app didn't fully uninstall the app, as `adb shell pm list packages` would still show the app. Don't ask me how. If/when this happens, you need to use `adb uninstall` to remove the package.)

Furthermore, I don't think that Xamarin.Android 4.7.8 will work properly on Mavericks. You will need the forthcoming 4.7.10 alpha.
Comment 13 Gerry 2013-06-19 12:41:22 UTC
Ok, I was able to get it to install.  What I did (whether this makes a difference or not I don't know):

1.  After getting the deploy issue from Mavericks I went back to my Surface Pro and rebuilt and installed on device (XS 4.0.8 Build 2, Xamarin.Android 4.7.8)
2.  Used settings/apps to remove my app
3.  Went back to mavericks and did a clean all/rebuild all, and install.

This time it worked.

As far as any issues with 4.7.8 on Mavericks, are there known issues that are documented somewhere?

For now I'm going to try using it on Mavericks.

Comment 14 Jonathan Pryor 2013-06-19 14:37:52 UTC
> As far as any issues with 4.7.8 on Mavericks, are there known issues that are
> documented somewhere?

Not exactly.

Many Xamarin.Android tools embed the Mono runtime, so all "older Mono 3.0"+Maverick issues will also potentially appear when using an anything prior to 4.7.10, e.g. the hang that this bug reports.

The Mono 2.10-based Xamarin.Android 4.6.x is reportedly fine on Maverick.
Comment 15 Mohit Kheterpal 2014-03-27 06:02:35 UTC
We have checked this issue and we are able to use XS 4.2.4 (build 266) on Maverick OSx 10.9.3. 

And as per comment 13 this issue is working fine.

Hence closing this issue.