Bug 12262 - debugger does not connect to physical devices (tried a number of iPads/iPhones) ignores breakpoints in code.
Summary: debugger does not connect to physical devices (tried a number of iPads/iPhone...
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
: 12321 ()
Depends on:
Reported: 2013-05-16 03:44 UTC by alexwhite68@gmail.com
Modified: 2013-05-28 16:16 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description alexwhite68@gmail.com 2013-05-16 03:44:54 UTC
I have the latest build of Xamarin studio, this problem occurs on stable, beta and alpha channels, I might get 10 minutes of debugging then it fails, closing studio down does not fix the problem, rebooting the mac does nothing, the only thing that seems to fix it sometimes is a reinstall by changing channels.

My mac is a good spec mac pro, less than a year old, my main devices are an iPhone4 and an iPad mini with the latest IOS versions on both, both a physically cabled to the mac (USB) the apps fire up but no debugging occurs, my main issue is I am debugging location stuff so needs to be done on the device and not the simulator.

adding breakpoints fails too and normally a restart of studio fixes this issue, but then the breakpoints are not hit.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2013-05-21 17:57:30 UTC
Can you try adding -f to the additional mtouch arguments in the project's iOS Build options page to see if that fixes it?
Comment 2 alexwhite68@gmail.com 2013-05-22 02:20:10 UTC
Hi Rolf,

thanks for the reply, the -f switch does make things better but not completely fixed, I get one debug session per run of the app, here are some steps that should help you reproduce the issue.

open an app in studio, set a breakpoint, run the app, the breakpoint is hit continue running the app, take the cable out of the device, the app is still running, now plug the cable back in and run another debug session from studio, the original app in my case is still running and studio cannot connect to it to get rid of it, so a manual closing of the app is required, when the next debug session is loaded none of the breakpoints are hit, only completely closing studio down and restarting allows the debugging to happen and the breakpoints to be hit.

Hope it help.

Comment 3 Rolf Bjarne Kvinge [MSFT] 2013-05-22 18:25:30 UTC
The app-killing on the device has already been fixed (but it'll take a while until it reaches a released version of MonoTouch).

The rest sounds like XS is not cleaning up the old debug session properly.
Comment 4 Jeffrey Stedfast 2013-05-28 16:15:48 UTC
there doesn't appear to be any XS bugs here, just the bug about mtouch not killing the app on launch
Comment 5 Jeffrey Stedfast 2013-05-28 16:16:41 UTC
*** Bug 12321 has been marked as a duplicate of this bug. ***