Bug 12213 - Right click not working on some Windows 7 boxes
Summary: Right click not working on some Windows 7 boxes
Status: RESOLVED DUPLICATE of bug 12153
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.0.4
Hardware: PC Windows
: Normal major
Target Milestone: 4.0.9 (from master)
Assignee: Mike Krüger
Depends on:
Reported: 2013-05-13 04:10 UTC by Mike James
Modified: 2013-06-27 09:20 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Mike James 2013-05-13 04:10:49 UTC
I've had two customers complain that since updating to 4.0.4 that they are unable to right click. It seems to be only Windows 7 users who have reported this to date.
Comment 1 Mikayla Hutchinson [MSFT] 2013-05-13 18:43:05 UTC
What is the GTK version shown in the About dialog?
What GTK# versions are shown in the Windows add/remove programs dialog?
Is it all right-clicking that doesn't work, or just the source editor?
Comment 2 Mike James 2013-05-17 06:13:27 UTC
The customer has reported the following version:

Gtk# for .Net 2.12.21
Comment 3 Mike Krüger 2013-05-17 06:15:53 UTC
And where does the right click not work and in which version ? 
(The source editor context menu should've been fixed in 4.0.5)
Comment 4 keven.corazza 2013-05-17 06:22:04 UTC
As I try to explain error appears in source editor when right mouse button is cliked. Hourglass appears and Xamarin Studio is blocked.
The error appears starting from 4.0.5.
I tried the last 4.0.8 and the error is not solved.
I've to use the "old" 4.0.3 where I don't have any problem.
Comment 5 Mike Krüger 2013-05-17 06:31:45 UTC
Ok I think it's the same issue as #12153

*** This bug has been marked as a duplicate of bug 12153 ***
Comment 6 PJ 2013-06-24 16:18:36 UTC
This bug was marked as fixed for Xamarin Studio 4.0.9, which is currently in the beta channel. Try it out!
Comment 7 keven.corazza 2013-06-27 09:20:35 UTC
I'm sorry but 4.0.9 doesn't solve the problem. Same behaviour.

I've to install the 4.0.3, the only one that works.