Bug 12210 - Xamarin Studio not detecting running emulator
Summary: Xamarin Studio not detecting running emulator
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0.5
Hardware: PC Windows
: --- normal
Target Milestone: 4.0.9 (from master)
Assignee: Bugzilla
Depends on:
Reported: 2013-05-12 06:39 UTC by Filippo Possenti
Modified: 2013-06-24 16:18 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Filippo Possenti 2013-05-12 06:39:14 UTC
Xamarin Studio is not detecting running emulators on my machine.

I tried starting them using Xamarin Studio (Run -> Start without debugging), using the Android AVD Manager and starting the AVD manager from Visual Studio 2010.

I also tried to run Xamarin Studio with administrative privileges, with no success.

I found several other bugs filed for the same (or a similar) issue, but no conclusive or helpful answer. Here follow some example:

Can you help me solve this issue?

Xamarin Studio shows the following details:

Xamarin Studio
Version 4.0.5 (build 4)
Installation UUID: 62fd08fd-348f-4f9f-a398-9120ac35dec7
	Microsoft .NET 4.0.30319.18034
	GTK 2.24.13
	GTK# (

Version: 4.6.4 (Indie Edition)
Android SDK: C:\Program Files (x86)\Android\android-sdk
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_21

Build Information
Release ID: 400050004
Build date: 2013-05-03 15:42:50Z
Xamarin addins: 603116b3659f75acbed00d7786768d2578832599

Operating System
Windows 6.1.7601.65536 (64-bit)
Comment 1 Mikayla Hutchinson [MSFT] 2013-05-13 14:25:20 UTC
Do the emulators show up in "adb devices"?
Comment 2 Filippo Possenti 2013-05-13 14:58:24 UTC
Nope, but you pointed me to the right direction.

The problem was a non-functioning adb.exe

The command prompt showed the following:
adb server is out of date.  killing...
ADB server didn't ACK
* failed to start daemon *
error: unknown host service

In particular, it seems I had an additional empty line in adb_usb.ini.

By killing adb.exe, removing the empty line and restarting it I was able to start debugging using Xamarin Studio.

The problem seems to be quite common in its nature. Even though it doesn't depend on your software, may I recommend to add a "diagnostic feature" to the list of available devices to help a user finding out the issue?

I'm stuck on "Deployment failed. FastDev directory creation failed" but that's another story. I'll open another bug, eventually.

Comment 3 PJ 2013-06-24 16:18:41 UTC
This bug was marked as fixed for Xamarin Studio 4.0.9, which is currently in the beta channel. Try it out!