Bug 12044 - Saving Program Options Causes Crashes
Summary: Saving Program Options Causes Crashes
Alias: None
Product: Runtime
Classification: Mono
Component: GC ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
: 12443 ()
Depends on:
Reported: 2013-04-30 09:32 UTC by Larry
Modified: 2016-12-15 00:05 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Crash report from the error (71.24 KB, text/rtf)
2013-04-30 17:08 UTC, Larry

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Larry 2013-04-30 09:32:54 UTC
If I go into program options and try to change the Bundle Signing (in any mode Release/Debug/etc.) it crashes... My only workaround is to launch the old monodevelop and change the option then rerun the Xamarin Studio. But this is very cumbersome.

I also cant change/edit the solution options.

Note it crashes when I click save not when I change to options... (and when I re-run it was not saved)
Comment 1 Mikayla Hutchinson [MSFT] 2013-04-30 15:17:04 UTC
Can you please attach the crash trace, and full version info from the "about" dialog?
Comment 2 Larry 2013-04-30 17:08:23 UTC
Created attachment 3898 [details]
Crash report from the error
Comment 3 Mikayla Hutchinson [MSFT] 2013-04-30 17:50:16 UTC
This is a GC bug. You may be able to work around it by upgrading or downgrading Mono.

*** This bug has been marked as a duplicate of bug 11804 ***
Comment 4 Larry 2013-04-30 17:58:09 UTC
I Have tried downgrading... Any of the Mono develop edit will no longer compile... and 4.0.3 does not fix the problem...

This code has no problem with any other projects just this one... its a pretty big project...

It does not crash at anytime just when saving the options...

I don't see how it's a deplicate of bug 11804
Comment 5 Mikayla Hutchinson [MSFT] 2013-04-30 19:05:53 UTC
Ir's a duplicate because the crash trace is the same:

0   libsystem_kernel.dylib        	0x98cb8a6a __pthread_kill + 10
1   libsystem_c.dylib             	0x912c0b2f pthread_kill + 101
2   libsystem_c.dylib             	0x912f74ec abort + 168
3   libmonosgen-2.0.dylib         	0x01093900 mono_handle_native_sigsegv + 624
4   libmonosgen-2.0.dylib         	0x010dda3d sigabrt_signal_handler + 109
5   libsystem_c.dylib             	0x912ab8cb _sigtramp + 43
6   ???                           	0xffffffff 0 + 4294967295
7   libmonosgen-2.0.dylib         	0x010dd9d0 sigusr1_signal_handler + 240
8   libsystem_c.dylib             	0x912f74ec abort + 168
9   libmonosgen-2.0.dylib         	0x0128d8a3 monoeg_g_logv + 243
10  libmonosgen-2.0.dylib         	0x0128d956 monoeg_assertion_message + 54
11  libmonosgen-2.0.dylib         	0x011f3b12 mono_gc_try_alloc_obj_nolock + 226
12  libmonosgen-2.0.dylib         	0x011f3e64 mono_gc_alloc_string + 84
13  libmonosgen-2.0.dylib         	0x011ae48a mono_string_new_size + 170
14  libmonosgen-2.0.dylib         	0x012222b0 ves_icall_System_String_InternalAllocateStr + 32

*** This bug has been marked as a duplicate of bug 11804 ***
Comment 6 Mikayla Hutchinson [MSFT] 2013-04-30 19:07:08 UTC
Also, my suggestion was to downgrade or upgrade the Mono *framework* not MonoDevelop, since that was reported as a workaround in the other bug report.
Comment 7 Larry 2013-05-13 15:35:17 UTC
Tried other versions..

Crashes when saving in 4.0.5

does not crash on any other project saving just this one project...
Comment 10 Mikayla Hutchinson [MSFT] 2013-05-29 10:46:29 UTC
*** Bug 12443 has been marked as a duplicate of this bug. ***
Comment 11 Vlad Brezae 2016-12-15 00:05:20 UTC
Closing as this is very old and the duplicate bug was reported fixed. Let us now if this is still an issue.