Bug 12034 - Find in files may result in UI hang
Summary: Find in files may result in UI hang
Status: RESOLVED DUPLICATE of bug 11533
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0.4
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
Depends on:
Reported: 2013-04-29 16:01 UTC by Yvan Rodrigues
Modified: 2013-06-28 02:51 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Crash dump (415.72 KB, text/plain)
2013-04-29 16:02 UTC, Yvan Rodrigues
Another dump (413.10 KB, text/plain)
2013-04-29 16:16 UTC, Yvan Rodrigues

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Yvan Rodrigues 2013-04-29 16:01:32 UTC
Possibly a regression of #11533.
Possibly related to #11371

This has happened a few times today.
- Search
- Find in Files...
- Whole solution

While the search is being performed, the UI is not particularly responsive. Then search completes and reports the matches. After trying to interact with the UI it freezes (I've tried waiting 10+ minutes) and must be force quit.

Dump attached
Comment 1 Yvan Rodrigues 2013-04-29 16:02:21 UTC
Created attachment 3891 [details]
Crash dump
Comment 2 Yvan Rodrigues 2013-04-29 16:16:17 UTC
Created attachment 3892 [details]
Another dump

I was able to close the dialog when it told me it was done searching. Then I was able to open the first result.

As soon as I tried scrolling down the UI was no longer responsive.
Comment 3 Mike Krüger 2013-06-28 02:51:32 UTC
The 11533 fix wasn't in 4.0.4 - try 4.0.9

*** This bug has been marked as a duplicate of bug 11533 ***