Bug 12019 - NUnit test runner fails for Mono 4.5 class library
Summary: NUnit test runner fails for Mono 4.5 class library
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit ()
Version: 4.0.4
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
Depends on:
Reported: 2013-04-29 06:35 UTC by Chris Leow
Modified: 2016-10-19 11:59 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Chris Leow 2013-04-29 06:35:40 UTC
Get the following in my Xamarin Studio log file:

  at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke (System.Runtime.Remoting.Proxies.RealProxy rp, IMessage msg, System.Exception& exc, System.Object[]& out_args) [0x00000] in <filename unknown>:0 
System.TypeLoadException: Could not load type 'System.Runtime.CompilerServices.ExtensionAttribute' from assembly 'BlastOutServer.UnitTests'.  at (wrapper xdomain-invoke) MonoDevelop.NUnit.External.NUnitTestRunner:GetTestInfo (string,System.Collections.Generic.List`1<string>)
  at (wrapper remoting-invoke-with-check) MonoDevelop.NUnit.External.NUnitTestRunner:GetTestInfo (string,System.Collections.Generic.List`1<string>)
  at MonoDevelop.NUnit.External.ExternalTestRunner.GetTestInfo (System.String path, System.Collections.Generic.List`1 supportAssemblies) [0x00008] in /Users/builder/data/lanes/monodevelop-lion-evolve_fixed/a8bf58d3/source/monodevelop/main/src/addins/NUnit/Services/ExternalTestRunner.cs:90 
  at (wrapper managed-to-native) System.Runtime.Remoting.RemotingServices:InternalExecute (System.Reflection.MethodBase,object,object[],object[]&)
  at System.Runtime.Remoting.RemotingServices.InternalExecuteMessage (System.MarshalByRefObject target, IMethodCallMessage reqMsg) [0x00000] in <filename unknown>:0 

Probably need to update test runner to cope with Mono / .NET 4.5 assemblies.
Comment 1 Johan Karlsson 2014-02-27 08:49:54 UTC
I can second this error. Running Xamarin studio on MacOS X. Tried to use NUnit from Nuget after updating project to 4.5. Removed all nunit references and fetched NUnit from Nuget again. Same error.
Comment 2 John Miller [MSFT] 2014-10-24 23:35:32 UTC
I am also getting this error occasionally with XS 5.6.2.
Comment 3 Jason Imison 2016-10-19 11:59:47 UTC
This was fixed at some point. Most of the Xamarin Studio assemblies are Mono / .NET 4.5  and the NUnit runner is used against those.