Bug 11959 - [CorDebugger] Debugging F# in Xamarin Studio 4.0.3 throws an error
Summary: [CorDebugger] Debugging F# in Xamarin Studio 4.0.3 throws an error
Status: RESOLVED DUPLICATE of bug 11304
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 4.0.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
Depends on:
Reported: 2013-04-25 09:27 UTC by Oldrich Svec
Modified: 2013-04-25 10:29 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Oldrich Svec 2013-04-25 09:27:56 UTC
I have installed Xamarin Studio 4.0.1 on Windows 8 x64 from http://monodevelop.com/Download . When I ran Xamarin, it got updated to 4.0.3. I have installed F# bindings. I have created new F# console project. When I run it, it works fine. When I set a break-point and run it, I get the following error.

System.Runtime.InteropServices.COMException (0x80070032): The request is not supported. (Exception from HRESULT: 0x80070032) at Microsoft.Samples.Debugging.CorDebug.NativeApi.ICorDebug.CreateProcess(String lpApplicationName, String lpCommandLine, SECURITY_ATTRIBUTES lpProcessAttributes, SECURITY_ATTRIBUTES lpThreadAttributes, Int32 bInheritHandles, UInt32 dwCreationFlags, IntPtr lpEnvironment, String lpCurrentDirectory, STARTUPINFO lpStartupInfo, PROCESS_INFORMATION lpProcessInformation, CorDebugCreateProcessFlags debuggingFlags, ICorDebugProcess& ppProcess) at Microsoft.Samples.Debugging.CorDebug.CorDebugger.CreateProcess(String applicationName, String commandLine, SECURITY_ATTRIBUTES processAttributes, SECURITY_ATTRIBUTES threadAttributes, Boolean inheritHandles, Int32 creationFlags, IntPtr environment, String currentDirectory, STARTUPINFO startupInfo, PROCESS_INFORMATION& processInformation, CorDebugCreateProcessFlags debuggingFlags) at Microsoft.Samples.Debugging.CorDebug.CorDebugger.CreateProcess(String applicationName, String commandLine, String currentDirectory, IDictionary`2 environment, Int32 flags) at MonoDevelop.Debugger.Win32.CorDebuggerSession.OnRun(DebuggerStartInfo startInfo) at Mono.Debugging.Client.DebuggerSession.<>c_DisplayClassc.b_a()
Comment 1 Jeffrey Stedfast 2013-04-25 10:27:53 UTC
The debugger backend for Win32 doesn't work with the 64bit .NET runtime, it only works with the 32bit .NET runtime (and even then, it's known to be broken in various ways).

Can you try installing the Mono runtime and debugging against that runtime instead of the Windows .NET runtime? The Mono Soft Debugger backend is much better and is currently the only debugger backend that is maintained.

To set the Mono runtime as the target runtime, a menu should appear in the "Project" menu (I think) that will allow you to select the Mono runtime.
Comment 2 Jeffrey Stedfast 2013-04-25 10:28:35 UTC

*** This bug has been marked as a duplicate of bug 11304 ***
Comment 3 Jeffrey Stedfast 2013-04-25 10:29:32 UTC
You could also try changing the build target to "Debug | x86"