Bug 11794 - Deployment unstable in 4.6.03 and 4.6.04
Summary: Deployment unstable in 4.6.03 and 4.6.04
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2013-04-15 11:14 UTC by ole.kristensen
Modified: 2016-08-03 15:29 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description ole.kristensen 2013-04-15 11:14:11 UTC
I have tried to update xamarin to 4.6.03 and 4.6.04. After this deployment to emulator and target has been
quite unstable. I only get one attempt,  then I have to reboot VS in order to make one more deployment.
This is the only info I get. Any idea?

Loaded assembly:
Loaded assembly:
Loaded assembly:
Loaded assembly:
Loaded assembly: Mono.Android.Support.v4.dll [External]
Loaded assembly: Mono.Android.dll [External]
Loaded assembly: System.Core.dll [External]
The program 'Mono' has exited with code 0 (0x0).

Rolling back to 4.6.02 solves the problem.

I run windows8 visual studio 2012.
Comment 1 Matt Swaffer 2013-04-21 15:07:28 UTC
Same issue on Windows 7 + VS Studio 2012 Ultimate. 

Possibly related: adb kill-server / adb start-server makes VS lose the device.

What I mean is after killing and restarting the server, VS can no longer find the device, even if I hit "refresh" in the Select Device pop-up. Restarting VS resolves this.  Don't know if it is related or not.
Comment 2 Matt Swaffer 2013-04-21 15:52:16 UTC
I just discovered quite by accident that changing the USB connection from "Mass Storage" to "Charge Only" seems to resolve this issue at least on this particular device.  (Casio GZone Commando)
Comment 3 ole.kristensen 2013-05-27 13:12:37 UTC
This problem still exists in Xamarin 4.6.06. I'm not able change USB connection in  Galaxy S III mini. I have rolled back to 4.6.02 in order to solve the problem
Comment 4 ole.kristensen 2013-05-30 05:45:00 UTC
seems that this is solved in 4.6.07