Bug 11717 - Unable to build to device
Summary: Unable to build to device
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: 6.1.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2013-04-10 16:08 UTC by Bobby Skinner
Modified: 2014-01-20 10:28 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Bobby Skinner 2013-04-10 16:08:34 UTC
Failed to deploy to the device for debugging.

Please note that i am doing a 30 day trial, so i have never had a successful build to the device with your tool. The simulator worked fine.

I am attempting to deploy the fieldservice example - unmodified other than the bundle ID

Please ensure your device is connected...
Connected to: Bobby Skinner’s iPad 2
error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
MonoTouch.MobileDevice.MobileDeviceException: Send Message Error (error: 0xe800002d)
  at MonoTouch.Installation.Device.StartService (MonoMac.CoreFoundation.CFString service) [0x00000] in <filename unknown>:0 
  at MonoTouch.Debugging.AppListService.GetApplicationListXml (MonoTouch.Installation.Device d) [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.Installer.KillApplication (MonoTouch.Installation.Device d, System.String appId) [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.Installer+<KillApplication>c__AnonStoreyD.<>m__16 (MonoTouch.Installation.Device d) [0x00000] in <filename unknown>:0
Comment 1 Rolf Bjarne Kvinge [MSFT] 2013-04-10 19:26:43 UTC
Can you try rebooting your device?

If a reboot doesn't fix it, can you then get the device log (from Xamarin Studio's menu: View -> Pads -> iOS Device Log)?
Comment 3 Bobby Skinner 2013-04-10 19:44:35 UTC
please also note that I can build to the device from Xcode

I initially had to change the bundle ID to make it match my wild card test provisioning profile, but this feels like a provisioning issue - do you have a tutorial on app setup under mono?
Comment 4 Bobby Skinner 2013-04-11 22:42:47 UTC
i iwas supposed to change the status, so i am since i did not hear back and yesterday the respons was very fast. i provided more info in the last two entries
Comment 5 Rolf Bjarne Kvinge [MSFT] 2013-04-24 17:45:13 UTC
Are you using MonoTouch 6.1? If so I suggest you update to the latest 6.2 release.
Comment 6 Bobby Skinner 2013-04-24 18:33:32 UTC
I don't know i installed your latest trial 4.0.3 build 13 - whatever it set up is what i am using - where do i find the mono version?
Comment 7 Rolf Bjarne Kvinge [MSFT] 2013-04-24 18:34:41 UTC
Open Xamarin Studio -> menu Xamarin Studio -> About Xamarin Studio -> Show Details and then just copy everything here.
Comment 8 Bobby Skinner 2013-04-24 19:34:53 UTC
=== Xamarin Studio ===

Version 4.0.4 (build 2)
Installation UUID: fc2b1d0a-8eed-43d4-9676-252e4c827bf4
	Mono 2.10.12 (mono-2-10/c9b270d)
	GTK 2.24.16
	GTK# (
	Package version: 210120000

=== Apple Developer Tools ===

Xcode 4.6.2 (2067.2)
Build 4H1003

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Xamarin.iOS ===

Version: (Trial Edition)
Hash: c4f6316
Build date: 2013-22-04 18:55:23-0400

=== Xamarin.Android ===

Version: 4.6.4 (Trial Edition)
Android SDK: /Users/bobby/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
Java SDK: /usr

=== Build Information ===

Release ID: 400040002
Git revision: a8bf58d398a13bcc7595f5f85adae04865a834d4
Build date: 2013-04-17 16:35:47+0000
Xamarin addins: f24db65837464cb72995ce5e84fa62fb0069724c

=== Operating System ===

Mac OS X 10.8.3
Darwin chewbacca.local 12.3.0 Darwin Kernel Version 12.3.0
    Sun Jan  6 22:37:10 PST 2013
    root:xnu-2050.22.13~1/RELEASE_X86_64 x86_64
Comment 9 Bobby Skinner 2013-04-24 19:36:40 UTC
it looks like 6.10 but it is what the environment installed for the trial so perhaps the trial is not up to date
Comment 10 Bobby Skinner 2013-04-24 20:39:23 UTC
i went to mono site and see a 2.10 then it jumps to 3.0.x I did not see a 2.2

Can you give me a link, Once i get this going can we reset my demo to get a full 30 days as well?
Comment 12 Bobby Skinner 2013-04-25 23:50:53 UTC
this worked, however i think the lack of testing bit me. I set a break point and it stops but after a couple of seconds the debugger disconnects. But if i don't set a break point it runs. I am encouraged that I was able to build and run on the device.

I would like to hold off on re starting my trial till the tested version is completed, since i am evaluating this to see if it is adequate for development, the debugging process is a big part of the process.

Thank you for your help.
Comment 13 Rolf Bjarne Kvinge [MSFT] 2013-04-26 07:52:22 UTC
Have in mind that if you put a breakpoint before AppDelegate's FinishedLaunching method has completed, iOS will enforce a timeout of ~15 seconds before your app is killed.

If that's not the case: does the app continue to execute when the debugger disconnects, or does it exit/crash?
Comment 14 Bobby Skinner 2013-04-26 09:36:55 UTC
I did have it in that method, and it did continue to run - just the debugger aborted after 2-3 seconds.

I have on many occasions placed beakpoints in applicationDidFinishLaunchingWithOptions and never had an issue with apple, but i can't say i have done that recently so perhaps that is a new restriction.

I will try somewhere else for testing over the weekend. I simply chose that because i knew it had to go there and I am new to C# (I am only trying your product) because you support Android and iOS (and windows mobile if that eventually matters - lol)  and we need to port our app to android. I would like to eventually maintain only one codebase and no option is good. Xamarin seems to be the best option. To quote Argo: "This is the best bad idea we have, by far."

I am impressed, but also repulsed which is I think about as good as a crossplatform approach gets. Qt is the other choice, if feels better to me because of my many years of C/C++ experience, but your product feels more mature. My fear is that my bosses may find it to expensive to justify over mono develop, so I want to be able to give them a solid report on how usable the IDE is, and that it justifies a price that is higher than the hardware we have to buy for everyone.

That did not belong in the debug ticket, but i wanted to let you know that your help is one of the best selling point for me to use - thank you
Comment 16 Akhilesh kumar 2014-01-20 10:28:32 UTC
As per bobby's comment 14, it seems that his issue is resolved.

So closing this issue by marking as verified.