Bug 11688 - Deadlock/hang when loading solution in MonoDevelop
Summary: Deadlock/hang when loading solution in MonoDevelop
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2013-04-09 13:47 UTC by Andres G. Aragoneses
Modified: 2013-04-09 14:12 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Andres G. Aragoneses 2013-04-09 13:47:46 UTC
If I try to load Banshee.sln in MD master (as of today) with mono 3.0.8 (master/0d3d43f), I'm getting deadlocks very frequently.

SIGQUIT output is:

"<unnamed thread>" tid=0x0x2b2d57832480 this=0x0x2aaaaaab0e70 thread handle 0x403 state : waiting on 0x400 : Event  owns ()
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitAny_internal (System.Threading.WaitHandle[],int,bool) <0xffffffff>
  at System.Threading.WaitHandle.WaitAny (System.Threading.WaitHandle[]) <0x00023>
  at MonoDevelop.Projects.Formats.MSBuild.MainClass.Main (string[]) <0x00196>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

"<unnamed thread>" tid=0x0x2aaab0568700 this=0x0x2aaaaaab0a80 thread handle 0x40b state : interrupted state owns ()
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Net.Sockets.Socket.Accept_internal (intptr,int&,bool) <0xffffffff>
  at System.Net.Sockets.Socket.Accept () <0x0007b>
  at System.Net.Sockets.TcpListener.AcceptSocket () <0x00023>
  at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.WaitForConnections () <0x00033>
  at System.Threading.Thread.StartInternal () <0x000a8>
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <0xffffffff>

"<unnamed thread>" tid=0x0x2aaabc298700 this=0x0x2aaaaaab0bd0 thread handle 0x411 state : interrupted state owns ()
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Net.Sockets.Socket.Receive_internal (intptr,byte[],int,int,System.Net.Sockets.SocketFlags,int&) <0xffffffff>
  at System.Net.Sockets.Socket.Receive_nochecks (byte[],int,int,System.Net.Sockets.SocketFlags,System.Net.Sockets.SocketError&) <0x00053>
  at System.Net.Sockets.Socket.Receive (byte[],int,int,System.Net.Sockets.SocketFlags) <0x0007b>
  at System.Net.Sockets.NetworkStream.Read (byte[],int,int) <0x0008b>
  at System.IO.BufferedStream.Read (byte[],int,int) <0x0026d>
  at System.Runtime.Remoting.Channels.Tcp.TcpMessageIO.StreamRead (System.IO.Stream,byte[],int) <0x0003f>
  at System.Runtime.Remoting.Channels.Tcp.TcpMessageIO.ReceiveMessageStatus (System.IO.Stream,byte[]) <0x00043>
  at System.Runtime.Remoting.Channels.Tcp.ClientConnection.ProcessMessages () <0x000af>
  at System.Runtime.Remoting.Channels.RemotingThreadPool.PoolThread () <0x001fb>
  at System.Threading.Thread.StartInternal () <0x000a8>
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <0xffffffff>

"<unnamed thread>" tid=0x0x2aaab076d700 this=0x0x2aaaaaab0930 thread handle 0x40d state : interrupted state owns ()
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.Thread.Sleep_internal (int) <0xffffffff>
  at System.Threading.Thread.Sleep (int) <0x00016>
  at MonoDevelop.Projects.Formats.MSBuild.MainClass/<WatchProcess>c__AnonStorey0.<>m__0 () <0x00021>
  at System.Threading.Thread.StartInternal () <0x000a8>
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <0xffffffff>
Comment 1 Mikayla Hutchinson [MSFT] 2013-04-09 14:07:18 UTC
That's not the MD process, it's the MSBuild builder process. Please provide the SIGQUIT output for the MD process.
Comment 2 Andres G. Aragoneses 2013-04-09 14:12:29 UTC
This is weird.

Unfortunately I don't reproduce it anymore.

What I did: renamed my ~/.config/MonoDevelop folder so MD could generate a new one. Opened a couple solutions or two, found out that I couldn't reproduce this bug anymore.

So I renamed back my backup settings folder to ~/.config/MonoDevelop, and tried to open the solution again, and still no bug. Tried two times more, still no bug.