Bug 11563 - Xamarin studio fails to recognize GTK# 2.12.20 during install
Summary: Xamarin studio fails to recognize GTK# 2.12.20 during install
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Duncan Mak
Depends on:
Reported: 2013-04-03 18:30 UTC by Andrey
Modified: 2015-08-25 07:12 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

the missed screenshot (39.58 KB, image/png)
2013-04-03 18:32 UTC, Andrey

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Andrey 2013-04-03 18:30:56 UTC
I've downloaded GTK# 2.12.20 for .NET and installed it from monodevelop.com.
Upon attempting to install monodevelop 4, the installer fails to recognize that GTK# is present on the system.

Restarting the system does not seem to help.

This is on Windows 7 (x64) Pro

The attached screenshot contains a the Programs and Features window in the background, displaying that 2.12.20 has been isntalled.
The command line is "dir \windows\assembly\GAC\g*"

And the window on top is the error from the installer.
Comment 1 Andrey 2013-04-03 18:32:13 UTC
Created attachment 3745 [details]
the missed screenshot
Comment 2 fenfir 2013-05-13 17:04:08 UTC
I had the same issue. I was able to workaround by intalling from CLI using the /passive flag.

msiexec /i XamarinStudio-4.0.1.msi /passive
Comment 3 Duncan Mak 2013-05-13 17:12:19 UTC
Could you try again by removing all existing GTK# installations and installing http://download.xamarin.com/GTKforWindows/Windows/gtk-sharp-2.12.21.msi?
Comment 4 Jon Goldberger [MSFT] 2013-09-06 15:37:38 UTC
Had the same issue. Instructions on comment 3 worked for me.
Comment 5 Step 2014-01-03 05:47:25 UTC
I had this issue with GTK# 2.12.22 and the suggestion from comment 2 solved it for me.
Comment 6 Lluis Sanchez 2015-08-25 07:12:47 UTC
Can't be reproduced anymore. Closing for now.