Bug 11516 - Installation of App (Debug or Release) crashes iPad and must restore
Summary: Installation of App (Debug or Release) crashes iPad and must restore
Status: RESOLVED DUPLICATE of bug 11099
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 6.2.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2013-04-02 07:08 UTC by Alistair Dyer
Modified: 2013-05-16 08:11 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Alistair Dyer 2013-04-02 07:08:41 UTC
I get the following error in the Application Output

error MT1107: Application failed to launch

This then causes the iPad to reboot and lock at the Apple loading screen, this means the iPad needs to be restored from a backup.  

I have tried uninstalling xcode and xamarin.studio but this still happens. I also cannot debug in the iPad simulator, I get the following error.

"The simulated application quit.

Click Relaunch to try again."

This used to work on the old version of monotouch and now is completely broken!  Please help!
Comment 1 Sebastien Pouliot 2013-04-02 07:32:49 UTC
Can you share the project with us? or a subset of it that reproduce the issue ?

Can you add the version numbers you're using ? 

The easiest way to get exact version information is to use the "Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" button and copy/paste the version informations (you can use the "Copy Information" button).
Comment 2 Alistair Dyer 2013-04-08 04:23:17 UTC

The version is 4.0.3 (build 13)

XCode version 4.6.1

Has anyone else reported this?
Comment 3 Sebastien Pouliot 2013-04-08 07:58:42 UTC
That's only the XS version, we need all version numbers (you can get them with the instructions from comment #1).

If you can duplicate this issue could you also attach the .app to the bug report (you can mark it private) so we might analyze what's going wrong. Thanks.
Comment 4 Alistair Dyer 2013-04-08 10:45:29 UTC
Hi, as per normal I only did half a job!  Sorry about that.

Below is the version info and I will attach the requested files.

Thanks for your help.

=== Xamarin Studio ===

Version 4.0.3 (build 13)
Installation UUID: 5cdac8e5-ba6a-4b66-bc9a-c938e277af43
	Mono 2.10.12 (mono-2-10/c9b270d)
	GTK 2.24.16
	GTK# (
	Package version: 210120000

=== Apple Developer Tools ===

Xcode 4.6.1 (2067)
Build 4H512

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: ed9807c
Build date: 2013-19-03 13:42:59-0400

=== Xamarin.Android ===

Version: 4.6.0 (Starter Edition)
Android SDK: /Users/dyera/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
Java SDK: /usr

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Build Information ===

Release ID: 400030013
Git revision: fae7c2bde0e8d51943fbd6afa22d7d2bb7a1192f
Build date: 2013-03-21 19:16:39+0000
Xamarin addins: 906a1edff23bcfd0ab7518463620a8ee506eaea2

=== Operating System ===

Mac OS X 10.8.3
Darwin administrators-Mac-mini.local 12.3.0 Darwin Kernel Version 12.3.0
    Sun Jan  6 22:37:10 PST 2013
    root:xnu-2050.22.13~1/RELEASE_X86_64 x86_64
Comment 8 Sebastien Pouliot 2013-04-08 15:43:23 UTC
Some tool added an empty entry inside your Info.plist which is causing this issue (or seems iOS really dislike that).

Did you only use Xamarin Studio for developing the application ? or recall manually editing that file ?
Comment 9 Alistair Dyer 2013-04-09 09:10:40 UTC
Thanks, that fixed it working on the iPad, very strange that it properly broke the whole iPad and needed a restore!

It however still doesn't work on the simulator, although I have created a test project and that doesn't work either.  Is that more of a problem with xcode or xamarin?
Comment 10 Sebastien Pouliot 2013-04-09 09:18:17 UTC

^ this entry is the root problem. For some reason iOS can't digest it and
starts a reboot loop.

AFAIK this entry could only have been written when using the Visual Studio addin (not Xamarin Studio). Did you use VS to develop (in part or completely) your application ?

> very strange that it properly broke the whole iPad and needed a restore!

Yes, I filled the a with Apple (#13601057) because iOS should really not brick itself in such cases.

> It however still doesn't work on the simulator,

We have not see any effect on the simulator. Something else could be wrong. Did you try to reset it ?

e.g. the "Reset Content and Settings..." in the iOS Simulator menu

Be aware that it will remove everything (app and data) from the simulator.
Comment 11 Mikayla Hutchinson [MSFT] 2013-04-09 14:41:55 UTC
As well as fixing the VS UI not to write bad values into the plist, we should make sure that the XS and VS build code strip out existing bad values when building the plist.
Comment 12 Alistair Dyer 2013-04-10 05:03:26 UTC
Hi I forgot to say that this issue started happening after I imported the project into VS 2012.

I have also tried your recommendations re: simulator but not joy.
Comment 13 Sebastien Pouliot 2013-04-10 07:49:22 UTC
Does that happen from VS ? XS ? or both ?

Can you run another application/sample, from VS or XS, on the simulator ? or is only your own application affected ?
Comment 14 Sebastien Pouliot 2013-05-16 08:11:47 UTC
Newer versions of the tools should not be generating this empty entry anymore.

*** This bug has been marked as a duplicate of bug 11099 ***