Bug 11470 - MonoDevelop does not start
Summary: MonoDevelop does not start
Alias: None
Product: Runtime
Classification: Mono
Component: Tools ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2013-03-28 21:08 UTC by Rudy Raab
Modified: 2013-04-04 10:24 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Log from running 'monodevelop' on console with MONO_LOG_LEVEL set to "debug" (52.00 KB, text/plain)
2013-03-28 21:08 UTC, Rudy Raab

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Rudy Raab 2013-03-28 21:08:05 UTC
Created attachment 3716 [details]
Log from running 'monodevelop' on console with MONO_LOG_LEVEL set to "debug"

Whenever I try to start MonoDevelop, it immediately exits (return code 0). No splash screen, error messages, or windows of any kind display, and no output is given on the console. 

I'm using MonoDevelop 4.0 with Mono 3.0.6 on OpenSUSE 12.3 x64 (kernel 3.7.10-1.1) with KDE 4.10.1. 

I have attached full console output from running it with MONO_LOG_LEVEL set to "debug".
Comment 1 Mikayla Hutchinson [MSFT] 2013-03-28 21:17:39 UTC
TBH I would guess a runtime crash as you're using an outdated Mono beta with AOT enabled.

The log appears to be incomplete, it stops in the middle of a runtime log message. Are you certain it's not crashing?
Comment 2 Rudy Raab 2013-03-28 22:33:13 UTC
I'm using the latest version of Mono available in any reasonably official OpenSUSE repository. 

The log is as complete as it gets-- I ran it several times and that's as far as it went. 

I also tried updating all my mono-related packages to slightly newer versions from the Mono:Factory repository and MD crashes just the same. The console output with debug level logging is exactly the same.
Comment 3 Rudy Raab 2013-04-04 10:24:03 UTC
Nevermind about this bug-- it's not one. I got it figured out; the reason it looked like I was using an outdated mono beta is that I still had a few symlinks for an older version hanging around. My system was defaulting to those even though the distro-provided packages should have been higher priority. 

Monodevelop is running now, and I'm closing this bug.