Bug 11402 - Global search should support specifying column
Summary: Global search should support specifying column
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: Trunk
Hardware: PC Mac OS
: Low normal
Target Milestone: ---
Assignee: Mike Krüger
Depends on:
Reported: 2013-03-25 21:16 UTC by Mikayla Hutchinson [MSFT]
Modified: 2013-03-27 01:29 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Mikayla Hutchinson [MSFT] 2013-03-25 21:16:48 UTC
The global search doesn't seem to support specifying column.

I tried somefile.cs:line,col and somefile.cs:line:col and neither worked - ideally both would.

Also, specifying the line only seems to work when the file: prefix is provided. Ideally it would switch the search into files-only mode, and work.
Comment 1 Mike Krüger 2013-03-26 04:05:05 UTC

file:line does work for me btw.
Comment 2 Mikayla Hutchinson [MSFT] 2013-03-26 17:56:37 UTC
Ah! The list goes blank when I type the colon, but it shows again when I type a number.

TBH this is confusing, could we fix it?
Comment 3 Mikayla Hutchinson [MSFT] 2013-03-26 18:13:26 UTC
I filed a different bug for that instead of reopening this one.
Comment 4 Mike Krüger 2013-03-27 01:29:32 UTC
hm, the thing is that this is parsed as category in that case and the category is empty that's why it blanks.