Bug 11208 - Attempting to Access Component Store Results in Crash
Summary: Attempting to Access Component Store Results in Crash
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0.1
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 4.2.3 (from master)
Assignee: Bojan Rajkovic [MSFT]
Depends on:
Reported: 2013-03-16 23:57 UTC by RobertLawrence
Modified: 2014-01-03 12:43 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Crash Details and Stack Trace (83.51 KB, text/plain)
2013-03-16 23:57 UTC, RobertLawrence
Xamarin Studio Logs (128.31 KB, application/zip)
2013-03-17 01:20 UTC, RobertLawrence
xamarin studio logs (28.01 KB, application/octet-stream)
2013-11-11 12:41 UTC, services

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description RobertLawrence 2013-03-16 23:57:12 UTC
Created attachment 3634 [details]
Crash Details and Stack Trace

Note this bug is for Xamarin Studio 4.0.1, however no exact match was in the product list.

I seem to be experiencing something odd with Xamarin Studio 4.0.1. If I click on the "Open Component Store" or "Get More Components" button, Xamarin Studio crashes.

Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000144

On my machine, the steps to reproduce are as follows:  launch Xamarin Studio, create any iOS based solution; select the "Edit Components..." context menu on the Components folder;click either "Open Component Store" or "Get More Components".

A window pops up, populates with some details of available components, but the icons for the components are missing.  Immediately, i get the spinning rainbow disc mouse pointer and the app stop responding. About 3-4 seconds later, the app crashes and asks if I want to report this to Apple.  (Crash details / stack trace attached.)

Machine is a Mid 2012 Apple MacBook Pro Retina, 15", 2.7GHz i7 and running OS X 10.8.3.

Xamarin Studio was first installed on this machine today (March 16th 2013).  The component store has never been sucessfully accessed from the application.
Comment 1 Bojan Rajkovic [MSFT] 2013-03-17 00:47:26 UTC
Hi Robert,

Could you please attach the contents of the Xamarin Studio log directory? You can find it by clicking Help -> Open Log Directory. Just zip the files up and attach them here. If you could also attach the full contents of the Apple crash reporting dialog that pops up, that would be helpful as well.
Comment 2 Bojan Rajkovic [MSFT] 2013-03-17 00:47:53 UTC
Ah, I see you already attached the full Apple stack trace. I still need the Xamarni Studio logs though.

Comment 3 RobertLawrence 2013-03-17 01:20:19 UTC
Created attachment 3635 [details]
Xamarin Studio Logs
Comment 4 RobertLawrence 2013-03-17 01:22:40 UTC
Hi Bojan, requested logs are include. 

 You will also see the updater log too, showing I ahd upgraded to the current "beta" releases.  I tried the newer beta as well, to see if it "fixed" the problem.  However, the behavior followed in the newer beta as well.
Comment 5 RobertLawrence 2013-03-21 07:50:24 UTC
I have updated to Xamarin Studio 4.0.2 build 18 via the Stable update channel and confirm the issue has persisted into the latest stable release.
Comment 6 Bojan Rajkovic [MSFT] 2013-04-04 10:23:51 UTC
I haven't been able to reproduce this at all, nor do the errors make any sense to me. Robert, can you update to 4.0.3 and see if the problem still persists?
Comment 7 RobertLawrence 2013-04-09 18:09:22 UTC
Bojan, problem still exists in 4.0.3.

However, I have noticed that the problem only exists when I am on my primary LAN (which has some web filtering / blocking of adware and malware).  The primary LAN uses OpenDNS and some of its filtering features.

If use the same laptop on a mobile WiFi hotspot, I am able to access to the component store.  At least now I have a "work-around".  

One thing OpenDNS does is if a site is blocked, the user is redirected to a custom block page.  I am wondering if there are any ad tracking / analytics that OpenDNS is blocking which the component store is using. Is it possible that OpenDNS's redirect may be causing unexpected results to be passed to Xamarin Studio which it can't parse?   

Regardless, Xamarin Studio should not crash due to any content filtering.  Worse case, I would expect a pop-up message with an error, and then let me continue using other features.  If it fails now, I loose any unsaved changes in my open projects.
Comment 8 Bojan Rajkovic [MSFT] 2013-04-09 18:13:33 UTC
Hi Robert,

Hmm, that's very strange. The issue here is that this is never actually getting back to Xamarin Studio, it's crashing in the Cocoa embedded web browser widget that we're using. It might be related to something we're doing with the widget though, so I'll test with OpenDNS as soon as I can. Thanks for the information—hopefully it'll be helpful.
Comment 9 RobertLawrence 2013-07-31 06:58:06 UTC
I have determined a bit more about the exact cause.  I am using OpenDNS on this network for filtering of adware/malware, etc.  I cleared DNS caches locally and watched what entries populated after attempting to access the component store and noticed "ssl.google-analytics.com" being queried each time I access the component store.

My OpenDNS filters were configured to block google-analytics.com and googleadservices.com.  This means that OpenDNS was returning the wrong IP for google-analytics, redirecting it to the IP of a blocked page.  

I have instructed OpenDNS to allow google-analytics.com on my network, flushed the DNS caches, and again tried the component store, which now works.

However, I still think that if DNS resolution fails (or returns a fake result), it shouldn't cause Xamarin Studio to quit unexpectedly.  If Xamarin dictates that using google-analytics is vital, wouldn't a popup stating that google-analyics couldn't be contacted be preferred??
Comment 10 RobertLawrence 2013-07-31 07:17:44 UTC
Easy to reproduce the crash with Mountain Lion.

Modify the Mac's /private/etc/hosts file with the following entries (simulates the response from OpenDNS when a domain is blocked).  google-analytics.com ssl.google-analytics.com

Flush the dns cache on the mac with: dscacheutil -flushcache;sudo killall -HUP mDNSResponder

Launch Xamarin Studio and attempt to access the component store. The component store window partially populates then Xamarin Studio unexpectedly quits.

Edit the hosts file and remove the line previously added.  Flush the cache again. Now the component store should work correctly.
Comment 11 Bojan Rajkovic [MSFT] 2013-07-31 14:11:45 UTC

Thanks for hunting this down! I spent a while trying OpenDNS and never got anywhere, never occurred to me to block some URLs. I'll have a look at fixing the crash ASAP, though from looking at the code using the Mark I Eyeball, I don't see anything very obviously wrong.
Comment 12 services 2013-11-11 12:40:36 UTC

I experience the same bug.

I have a direct, standard connexion to the Internet, a clean and fresh install.

For the moment, I use the starter Xamarin for iOS.
4.013 build 38

Mac :
10.8.5 OSX
Mac Mini 2,66ghz Core 2 duo / 8go DDR3

I'd like to purchase the Indie edition, use components, and maybe also build Android apps...

But I'm stuck with this...

Please help : I can reproduce steps, if you like.

( logs attached )
Comment 13 services 2013-11-11 12:41:32 UTC
Created attachment 5393 [details]
xamarin studio logs

xamarin studio logs
Comment 14 services 2013-11-14 14:58:03 UTC
Hi guys,

issue solved in Xamarin Studio 4.2

thanks Andrew :)

Comment 15 Bojan Rajkovic [MSFT] 2013-12-11 09:55:59 UTC
Should be fixed in the master branch, but I'm not sure when it will make it to a release next.
Comment 16 Mohit Kheterpal 2014-01-03 12:43:06 UTC
Today we have checked this issue with following builds :

XS 4.2.3 (build 24)

We are not getting any crash when we click on "Open Component Store" or "Get More Components". And we are able to add new components in iOS project from component store successfully.

Screencast : http://screencast.com/t/3QzxIP83bzpm

Hence closing this issue.