Bug 11092 - When debugging project inside a symlinked folder, breakpoint is not hit
Summary: When debugging project inside a symlinked folder, breakpoint is not hit
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: Trunk
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
Depends on:
Reported: 2013-03-12 19:24 UTC by Andres G. Aragoneses
Modified: 2013-08-06 05:15 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Andres G. Aragoneses 2013-03-12 19:24:58 UTC
Steps to reproduce:

1) Create a folder and a symlink to the folder:

:~/$ cd Code
:~/Code$ ln -s testdir testsymlink
:~/Code$ cd testsymlink

2) Open MD, create a solution inside ~/Code/testsymlink

3) Close MD. Open MD again, and open the solution created inside ~/Code/testsymlink/ (this step is actually a workaround to bug 11091.)

4) Open Main.cs and put a breakpoint in the Console.WriteLine call.

5) Press play button to start debugging.

Current results: breakpoint is not hit.
Expected results: breakpoint is hit.
Comment 1 Andres G. Aragoneses 2013-03-12 19:26:48 UTC
Oops, correcting summary.
Comment 2 Jeffrey Stedfast 2013-03-27 18:44:28 UTC
Looks like you just need to clean the build and then rebuild and it'll work (that fixed it for me, at least)
Comment 3 Andres G. Aragoneses 2013-03-28 04:35:23 UTC
Tried that, but didn't work :(
Comment 4 Jeffrey Stedfast 2013-03-28 14:33:32 UTC
can you tar up a sample with a symlink? I'm just not able to reproduce this
Comment 5 Jeffrey Stedfast 2013-08-05 12:54:06 UTC
this should be fixed
Comment 6 Andres G. Aragoneses 2013-08-06 05:15:25 UTC
It's true, I just tested it! Sorry for not getting back earlier, I completely forgot about comment#4. Thanks