Bug 11082 - Unable to add a reference to a Portable Lib for Android
Summary: Unable to add a reference to a Portable Lib for Android
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2013-03-12 14:36 UTC by Alek Slater
Modified: 2013-03-15 06:28 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Android Portable and iOS Portable Test Solution (34.20 KB, application/zip)
2013-03-13 01:29 UTC, Alek Slater

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Alek Slater 2013-03-12 14:36:43 UTC
If I create a new Solution, with an Android project, an iOS project and a portable lib project. I'm able to add a reference to the portable lib for the iOS project, but not for the Android project.
Comment 1 Mikayla Hutchinson [MSFT] 2013-03-12 18:01:56 UTC
What OS/IDE?
Comment 2 Alek Slater 2013-03-13 01:13:36 UTC
Xamarin Studio v 4.0.1 (build 9) on a Mac OS X 10.8.2
Comment 3 Alek Slater 2013-03-13 01:29:37 UTC
Created attachment 3591 [details]
Android Portable and iOS Portable Test Solution

Added a solution where I experience this. Notice You can add the Portable Lib reference to the iOS project, but not to the Android one.
Comment 4 Mikayla Hutchinson [MSFT] 2013-03-13 12:55:38 UTC
Work fine for me in latest Xamarin Studio builds, I think Jeff fixed this recently.
Comment 5 Alek Slater 2013-03-13 13:06:49 UTC
It certainly does not work in Xamarin Studio v 4.0.1, with Xamarin.Android
Version: 4.6.0 (Business Edition) and Xamarin.iOS Version: (Business Edition).

When I click to Edit references in the Android Project, it lists 2 projects, 1 the ios project which obviously should be incompatible (as it states).
The other one is the Portable library, which should be compatible, but is also listed as incompatible,
it says something like: Incompatible target framework: v.NETPortable, Version=v4.0,Profile=Profile1.

If its fixed, when do you plan on releasing a fix to the public for it?
Comment 6 Mikayla Hutchinson [MSFT] 2013-03-13 13:21:39 UTC
I can't promise a timeline - we have regular releases but they have to go though QA cycles.

There is a 4.0.2 on the Beta updater channel which may include it.
Comment 7 Alek Slater 2013-03-14 11:44:56 UTC
What's the best place to check for information about beta updater channel releases?
I.e. commit messages or release notes?
Comment 8 Alek Slater 2013-03-14 22:46:51 UTC
I've tried Version 4.0.2 (build 18) and I can confirm that the bug is still present there.
I.e. I'm not able to add a reference to the Android projects for portable libs.
I also tried to create a new project using this updated Xamarin studio (and android / ios), still no go.
Comment 9 Mikayla Hutchinson [MSFT] 2013-03-14 22:58:20 UTC
Then it'll be in 4.0.3.
Comment 10 Alek Slater 2013-03-14 23:22:10 UTC
Brilliant, thanks Michael ;)
Comment 11 Alek Slater 2013-03-15 06:28:01 UTC
In case other people see this, the issue is present in both Alpha, Beta and Stable Update channels.