Bug 1108 - Monodevelop won't launch at all on OS X 10.5.8
Summary: Monodevelop won't launch at all on OS X 10.5.8
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.8
Hardware: Macintosh Mac OS
: Lowest normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2011-09-28 14:00 UTC by Lukas Oskarsson
Modified: 2013-01-14 04:59 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Lukas Oskarsson 2011-09-28 14:00:48 UTC

I've got an iMAc with Mac OS X version 10.5.8.

Tried Monodevelop 2.6 and 2.8 Beta 3, it won't launch at all?

Comment 1 Jeffrey Stedfast 2011-09-28 14:08:39 UTC
MacOS X 10.*5*.8? or 10.6.8?
Comment 2 Jeffrey Stedfast 2011-09-28 14:10:00 UTC
Also, what version of MonoFramework do you have?
Comment 3 Lukas Oskarsson 2011-09-29 05:27:09 UTC

* I'm using "Mac OS X version 10.5.8".
* Downloaded "Latest Stable Version: 2.10.5".

Comment 4 Alan McGovern 2011-09-29 07:41:50 UTC
Can you open a terminal and type:

open -a MonoDevelop

and then paste all the output of that to this bug report. This will only work if MonoDevelop has been copied to your Applications folder.

Could you also attach the log file which should be found in the subdirectory "Library/Logs/MonoDevelop-2.7/MonoDevelop.log" in your home folder. So the full path would be something like: "/Users/alan/Library/Logs/MonoDevelop-2.7/MonoDevelop.log". This log file may not exist if MonoDevelop is not launching at all, so don't worry if it's not there.
Comment 5 Lukas Oskarsson 2011-10-02 12:26:13 UTC
Got the following "LSOpenFromURLSpec() failed with error -10810."?

As you mentioned there is no "MonoDevelop.log"

Comment 6 Alan McGovern 2011-10-02 18:33:45 UTC
This was caused by MonoDevelop using some system functions which only exist in MacOS 10.6 or higher. We've put in a fix to disable these calls on older versions of MacOS so 2.8 final should be able to run on MacOS 10.5.
Comment 7 Lukas Oskarsson 2011-10-03 02:38:20 UTC
Thank's for the help, I'll wait for the final then!

Comment 8 Lukas Oskarsson 2011-10-05 14:04:04 UTC
Downloaded MonoDevelop 2.8 today, still doesn't wont to start?

Got the same output "LSOpenFromURLSpec() failed with error -10810".
Comment 9 Marek Safar 2011-11-15 14:14:13 UTC
Try to update your operating system, 10.5 is quite low on our priority list
Comment 10 Alan McGovern 2013-01-14 04:59:11 UTC
We decided that supporting MacOS less than 10.6.8 was going to be too much of a burden (especially since apple no longer support it) so we will not be releasing new versions of MonoDevelop which work on 10.5.x. The reasons for this are firstly that we'd have to disable some features in MonoDevelop itself and secondly that some of the essential third party code we use do not support 10.5.x anymore either.