Bug 11070 - Autocompletion broken completely
Summary: Autocompletion broken completely
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Mike Krüger
Depends on:
Reported: 2013-03-12 10:08 UTC by Andor Uhlar
Modified: 2013-03-13 10:21 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Log file (4.19 KB, application/octet-stream)
2013-03-12 10:08 UTC, Andor Uhlar
Log file (700 bytes, application/octet-stream)
2013-03-12 15:22 UTC, Andor Uhlar

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Andor Uhlar 2013-03-12 10:08:21 UTC
Created attachment 3579 [details]
Log file

On Windows 7 x64, Xamarin Studio 4.0, build 2003

I experienced the same problem as https://bugzilla.xamarin.com/show_bug.cgi?id=10558, and the fix described there fixed the "not being able to start" part of the issue. However, after creating a new project and typing anything, as soon as autocompletion is triggered (both manually and automatically), an error pops up, rendering code editing impossible. The autocompletion list is not shown. The log also displays some other error, but that's not shown inside the editor and doesn't seem to cause any errors that I can detect.
Comment 1 Mike Krüger 2013-03-12 11:52:21 UTC
Seems you're mixing 4.0 and 4.0.2 assemblies - 4.0 shouldn't have a PlainText property there - but 4.0.2.

Something got messed up with your xamarin studio installation - which version are you using ?
Comment 2 Andor Uhlar 2013-03-12 11:54:32 UTC
The "official" version from the monodevelop home page (http://monodevelop.com/Download).
Comment 3 Mike Krüger 2013-03-12 15:09:11 UTC
Can't repro it - have you done a clean install ? This bug occurs when a wrong dll is loaded.
Comment 4 Andor Uhlar 2013-03-12 15:22:12 UTC
Created attachment 3582 [details]
Log file

Complete reinstall with redownloaded installers. Vanilla install (eg. didn't copy over DLLs from other bug) results in Xamarin Studio not starting, same error message as the one I experienced at first. Log attached.
Comment 5 Andor Uhlar 2013-03-12 15:32:59 UTC
Also, I forgot to mention that the error message is identical to the one in the bug report I linked with the exception that parts of mine is in my native language, Hungarian.
Comment 6 Mikayla Hutchinson [MSFT] 2013-03-12 18:17:57 UTC
Try this, it includes the fixes from the linked report:

Unfortunately the links on monodevelop.com have not been updated yet, but that should be fixed soon.
Comment 7 Andor Uhlar 2013-03-13 10:21:00 UTC
Yes, it seems that this was the issue, that update fixed it! While I'm still here, I'd like to mention that the Xamarin Studio installer from http://xamarin.com/download also downloads 4.0, the incorrect version.