Bug 10734 - International characters in bundle display name
Summary: International characters in bundle display name
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 4.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
Depends on:
Reported: 2013-02-27 08:44 UTC by Linn
Modified: 2013-02-28 15:15 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Print screen (30.01 KB, image/png)
2013-02-27 08:47 UTC, Linn
info.plist (1.29 KB, application/octet-stream)
2013-02-28 10:34 UTC, Linn

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Linn 2013-02-27 08:44:10 UTC
Description of Problem:
I use a international letter ø i bundle display name , but it gets displayed like ? (question mark). I use Xamarin studios. My co worker used monodev, and does not have the same problem. Bug or anyone any ideas ?

Steps to reproduce the problem:
1. Put any international character in info.plist -  bundle display name. For example ø
2. Run application

Actual Results:
? (question mark)
Weird letters or none at all

Expected Results:

How often does this happen? 
All the time

Additional Information:
Comment 1 Linn 2013-02-27 08:47:00 UTC
Created attachment 3499 [details]
Print screen
Comment 2 Mikayla Hutchinson [MSFT] 2013-02-28 00:16:52 UTC
Does it display correctly if you open the Info.plist inside the app bundle?

I suspect this might be a bug in our binary plist writing code.
Comment 3 Linn 2013-02-28 05:39:53 UTC
It looks correctly in the file(under advanced) if that is what you mean. I tried opening it in Xcode, looks good there to, but when I run, it does not (simulation or on phone)
Comment 4 Jeffrey Stedfast 2013-02-28 10:23:20 UTC
Linn: can you attach an Info.plist file with some international characters?

Unfortunately, I am internationally-challenged :-)

Comment 5 Linn 2013-02-28 10:31:24 UTC
Her are some fro you Ø Æ Å ø æ å

Se http://support.apple.com/kb/PH6800.

I m attaching my info.plist as well
Comment 6 Linn 2013-02-28 10:34:31 UTC
Created attachment 3512 [details]
Comment 7 Jeffrey Stedfast 2013-02-28 11:45:17 UTC
Awesome! thanks so much
Comment 8 Jeffrey Stedfast 2013-02-28 15:15:24 UTC
fixed in git, will hopefully make it into the 4.0.2 release