Bug 10705 - Unable to determine licence edition
Summary: Unable to determine licence edition
Status: RESOLVED DUPLICATE of bug 12594
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.8.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2013-02-26 17:38 UTC by dreamothee
Modified: 2013-06-09 15:47 UTC (History)
7 users (show)

Is this bug a regression?: ---
Last known good build:

Xamarin Studio Activation Process (31.31 KB, image/png)
2013-02-26 17:38 UTC, dreamothee

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description dreamothee 2013-02-26 17:38:11 UTC
Created attachment 3491 [details]
Xamarin Studio Activation Process


I've the business edition of xamarin licence.
I've already install and activate the mono for android licence on Windows 7.
But now, I'm using Windows 8. So, I've install Windows 8 on the same computer (keeping Windows 7 and using dual boot). 
I've also installed Xamarin Studio.

But, I run Visual Studio 2012 and create a new mono for android project and when I build it I got the following error :
"C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(286,2): error XA9010: Unable to determine license edition."

I've also tried to make the same with Xamarin Studio but I go in an infinite loop (look at the attachement screenshots) in the activation process.



Comment 1 Bojan Rajkovic [MSFT] 2013-02-26 17:58:30 UTC

Did you run either IDE as administrator? If so, you're experiencing bug #10390, which is triggered by your IDE not being able to read your license file. You'll need to either give the license file proper permissions, or delete it and reactivate when not running as administrator.
Comment 2 dreamothee 2013-02-26 18:04:27 UTC
I try to run as an administrator and I also try to add full control to the file but I still got the issue...
Comment 3 pdangelo22@gmail.com 2013-04-11 23:10:34 UTC
i'm having this issue in VS 2012 running as an administrator. if i rebuild all, it gets resolved. any fix for this?
Comment 4 Atsushi Eno 2013-05-22 14:54:20 UTC
Bojan: could this be also stale license state at server side? Any way to diagnose more?
Comment 5 Bojan Rajkovic [MSFT] 2013-05-22 14:59:53 UTC
That message comes from XA itself—it shouldn't have anything with the server-side state. I've checked out Tim's licenses, and they're all fine (not expired, have activations left, etc.).
Comment 6 Jonathan Pryor 2013-05-22 19:44:00 UTC
Please run the following commands:

> "%ProgramFiles(x86)%\MSBuild\Xamarin\Android\mandroid.exe" --version > %TMP%\o.txt 2>%TMP%\e.txt
> NOTEPAD %TMP%\o.txt
> NOTEPAD %TMP%\e.txt

What are the contents of %TMP%\o.txt and %TMP%\e.txt?
Comment 7 maksimko 2013-05-27 14:41:35 UTC
Same issue with Xamarin.Android business or starter editions activation.
Beta channel, Mac OSX 10.8.3.

Stable works fine.
Comment 8 Philipp 2013-06-03 11:17:05 UTC
Having this issue as well.
o.txt = mandroid Business
e.txt is empty
Comment 9 Jonathan Pryor 2013-06-03 13:57:25 UTC
WORKAROUND: restart Xamarin Studio.
Comment 10 Alan McGovern 2013-06-09 15:47:54 UTC
We're tracking the fix in bug #12594. Thanks for reporting the issue!

*** This bug has been marked as a duplicate of bug 12594 ***