Bug 10533 - Unable to build using Mac Build Host
Summary: Unable to build using Mac Build Host
Status: VERIFIED DUPLICATE of bug 11326
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Vinicius Jarina
Depends on:
Reported: 2013-02-21 10:24 UTC by Allie Miller
Modified: 2013-05-30 10:59 UTC (History)
8 users (show)

Is this bug a regression?: ---
Last known good build:

Build Server Log Text (128.86 KB, text/plain)
2013-02-21 10:24 UTC, Allie Miller
Visual Studio error for debugging new solution (24.78 KB, image/jpeg)
2013-02-24 18:03 UTC, Graham Moore

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Allie Miller 2013-02-21 10:24:55 UTC
Created attachment 3443 [details]
Build Server Log Text

I am not able to debug the solution using the Mac build host. All the connectivity appears to be OK and I am able to connect to the build host.

I would like to be able to successfully build this using the new tools as it is my core project at present. The solution was created using VS and MonoDevelop and project linker etc. Maybe creating the solution from scratch in VS may be the best option.

It appears to build successfully however there is a manifest error. See log output below:

[2013-02-20 21:49:36.8] Starting /Developer/MonoTouch/usr/bin/mtouch -sdkroot "/Applications/Xcode.app/Contents/Developer" --entitlements
[2013-02-20 21:49:36.8] stdout: 8020ec004d9aae22db1b1cd896cbe03114f4a4d8 MonoTouch Business 2013-09-10T23:09:32
[2013-02-20 21:49:36.9] 
[2013-02-20 21:49:36.9] Handling with command: [StartDebugProxy: CommmandUrl=StartDebugProxy] (11)
[2013-02-20 21:49:36.9] Attempting to acquire command execution lock, timeout set to 00:10:00
[2013-02-20 21:49:36.9] Command [StartDebugProxy: CommmandUrl=StartDebugProxy] finished (11)
[2013-02-20 21:49:36.9] Got connection from Visual Studio : Waiting application... (output)
[2013-02-20 21:49:36.9] Starting /Developer/MonoTouch/usr/bin/mtouch -sdkroot "/Applications/Xcode.app/Contents/Developer" --entitlements
[2013-02-20 21:49:36.9] Got connection from Visual Studio: (sdb)
[2013-02-20 21:49:37.7] stdout: 8020ec004d9aae22db1b1cd896cbe03114f4a4d8 MonoTouch Business 2013-09-10T23:09:32
Mono.IOS.VisualStudio.Utilities.ErrorReportManager Error: 0 : Failed to run application.
Mono.IOS.VisualStudio.Utilities.ErrorReportManager Error: 0 : The remote server returned an error: (500) Internal Server Error. (Build Server)
Operation status: Operation failed
HTTP status: 500 (Internal server error)
Exception: System.Net.WebException (The remote server returned an error: (500) Internal Server Error.
at System.Net.HttpWebRequest.GetResponse()
at MonoTouch.Tools.Utilities.ServerIO.Server_GetResult[T](ServerIOState state, String command, IDictionary`2 queryVariables)
Server returned an error. The remote server returned an error: (500) Internal Server Error.
Server error code: 500
Internal Server Error

[2013-02-20 21:49:37.9] 
[2013-02-20 21:49:37.9] Handling with command: [DebugApplication: CommmandUrl=DebugApplication] (11)
[2013-02-20 21:49:37.9] Attempting to acquire command execution lock, timeout set to 00:10:00
[2013-02-20 21:49:37.9] Error: Command [DebugApplication: CommmandUrl=DebugApplication] failed.
[2013-02-20 21:49:37.9] Exception: Exception type: System.InvalidOperationException
[2013-02-20 21:49:37.9] Missing build manifest.
[2013-02-20 21:49:37.9] at Mtb.Server.Commands.DebugApplication.HandleRequest (ILoggingHelper logger) [0x00000] in <filename unknown>:0 
[2013-02-20 21:49:37.9] at Mtb.Server.BaseCommand.OnRequest (System.Net.HttpListenerContext context) [0x00000] in <filename unknown>:0 
[2013-02-20 21:49:37.9] at Mtb.Server.Listener.OnRequest (System.Object state) [0x00000] in <filename unknown>:0 
[2013-02-20 21:49:37.9] Starting /Developer/MonoTouch/usr/bin/mtouch -sdkroot "/Applications/Xcode.app/Contents/Developer" --entitlements
[2013-02-20 21:49:38.7] stdout: 8020ec004d9aae22db1b1cd896cbe03114f4a4d8 MonoTouch Business 2013-09-10T23:09:32
[2013-02-20 21:49:38.9] 
[2013-02-20 21:49:38.9] Handling with command: [ChangeActiveApplication: CommmandUrl=ChangeActiveApplication] (11)
[2013-02-20 21:49:38.9] Attempting to acquire command execution lock, timeout set to 00:10:00
[2013-02-20 21:49:38.9] Command [ChangeActiveApplication: CommmandUrl=ChangeActiveApplication] finished (11)
Comment 1 Graham Moore 2013-02-21 16:58:40 UTC
Although this was found while using the Beta release, the problem still persists in the released version.
Comment 2 Vinicius Jarina 2013-02-22 09:18:56 UTC
This is happening with any project? 

Or only with one specific project?

Thank you.
Comment 3 Graham Moore 2013-02-24 18:03:13 UTC
Created attachment 3471 [details]
Visual Studio error for debugging new solution

Visual Studio error which occurred after using solution in Xamarin Studio.
Comment 4 Graham Moore 2013-02-24 18:05:56 UTC

It's not happening for every solution. This particular error is occurring for a solution I originally created in VS but mainly developed in Monodevelop. 

As it appeared to be a solution issue, I created a brand new solution in Visual Studio and began to build up the source files. This solution would build successfully on the build host and debug correctly. Then I ran into an issue where a CollectionView constructor call was causing the app to terminate with SIGTERM. Initially I had no idea what was causing this. So I started trying to debug the solution in Xamarin Studio on the Mac host.

Figured out that the crash above was due to the fact that I was using an IOS 6 feature and trying to run on an IOS 5 simulator. Corrected this problem and it ran fine on Xamarin Studio. However when I returned to using VS the solution now started to throw the same error when I try to debug. This error is thrown by VS, however it does then begin the debug session on the build host. See attached jpeg for error in VS.

Even stranger, this solution crashes when running under VS/Build host but runs successfully on the device and in the simulator from Xamarin Studio.

As you can see the initial error occurs in both cases I have outlined, however in the first the debug session does not start, in the second case it does start.

Comment 5 Vinicius Jarina 2013-02-25 09:56:43 UTC
Xamarin Studio remove the '.' from the AssemblyName, that confuses the VisualStudio, try to rename the Target to something without a '.' and you will probably be able to open the same solution on VS and XS.  :)
Comment 6 Graham Moore 2013-02-25 17:19:02 UTC

Thank you for the response. That's quite an unfortunate problem. I'm not 100% sure of the interaction between Xamarin Studio and Visual Studio here, however I removed the "." from the assembly settings in Visual Studio.

Once I had cleaned the simulator of apps and let VS/build host repopulate the simulator all worked correctly. I am now able to debug via the build host. Also using VS and Xamarin Studio at the same time can confuse the simulator.

Thanks again for your help. Hopefully this issue can be fixed so that any valid character can be used in assembly names.
Comment 7 Vinicius Jarina 2013-02-27 10:46:30 UTC
XS should not remove the '.' from projects with '.' in the name, this confuses Visual Studio. We should let the csproj as-is.
Comment 8 Mikayla Hutchinson [MSFT] 2013-02-27 13:35:25 UTC
Why does this confuse VS?

The sanitization of the dll name is done for a reason: https://bugzilla.xamarin.com/show_bug.cgi?id=252
Comment 9 Mikayla Hutchinson [MSFT] 2013-02-27 13:39:46 UTC
My reading of the situation is:
* VS does not have the fix for bug 252, so apps can crash on simulator
* because VS does not have the fix, it gets confused when XS applies the fix
Comment 10 Vinicius Jarina 2013-03-26 15:26:46 UTC
This is the same issue: https://bugzilla.xamarin.com/show_bug.cgi?id=11326

*** This bug has been marked as a duplicate of bug 11326 ***
Comment 11 Mohit Kheterpal 2013-05-30 10:59:29 UTC
Today we have checked this issue on following builds :

VS 2012
MTVS 1.2.103
Mono 2.10.12

If name of the application contains periods in between it and when we try to
debug the application it deploys on device/simulator successfully.

It create .exe file without periods.

Like if name of application is "create.new.test.1" then it create exe with name

As this bug is duplicate of bug 11326. And bug 11326 is verified.
Hence changing its status to verified.