Bug 10330 - Visual C++ Runtime error upon exiting MonoDevelop 3.0.6
Summary: Visual C++ Runtime error upon exiting MonoDevelop 3.0.6
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 3.0.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2013-02-15 17:18 UTC by John Colgrove
Modified: 2014-02-25 19:41 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

File describing error (272 bytes, text/plain)
2013-02-15 17:18 UTC, John Colgrove

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description John Colgrove 2013-02-15 17:18:00 UTC
Created attachment 3388 [details]
File describing error

Every time I exit out of MonoDevelop on my laptop I get a runtime error (see attached file). How do I fix this? I'm on Windows 8 Pro and yes my computer is up to date. I have both Mono 3.0.3 and .net Framework 4.5 installed. That shouldn't make a difference but I thought I'd mention that also. The error happens using either framework. The error seemed to show up right after a failed install of Windows SDK 7.1. As far as I know, none of the SDK components actually installed though. Although, I am thinking the Visual C++ Runtime may have gotten damaged when that happened. If that is the culprit, is it a good idea to go ahead and reinstall?

As I wrote this, I realized I never actually tried reinstalling MonoDevelop. I'll try that now and see if that fixes the issue.
Comment 1 John Colgrove 2013-02-15 17:44:47 UTC
Tried reinstalling but didn't fix the error.
Comment 2 Mikayla Hutchinson [MSFT] 2013-02-15 19:14:41 UTC
We'll be releasing a new version of GTK# soon that may fix this.
Comment 3 John Colgrove 2013-02-16 21:53:05 UTC
Cool, thanks.
Comment 4 Lluis Sanchez 2013-03-05 20:46:49 UTC
Hi Josh, are you still getting this error in Xamarin Studio?