Bug 10328 - User is shown "Registration code in use" dialog after successful activation (if they previously failed activation)
Summary: User is shown "Registration code in use" dialog after successful activation (...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Activation ()
Version: 1.3.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2013-02-15 15:04 UTC by Peter Collins
Modified: 2015-07-22 14:23 UTC (History)
8 users (show)

Tags: error improvement
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Peter Collins 2013-02-15 15:04:26 UTC
If the user fails to activate one or more times due to a lack of workstations, and then successfully completes an activation in the same VS instance, they are shown an Activation Incomplete error as well as an Upgrade Successful dialog.


This happens with both X.iOS for VS and X.A for VS, in VS2010 and VS2012.

Steps to Reproduce:
1) Ensure there is no license on disk.
2) Log into the following account:
3) Open or create a new X.iOS or X.A project; activation should fail and project should be unloaded.
4) Log out of this account, and into an account with a valid activation code with workstations.
5) Reload the project that was previously unloaded.
6) User is shown upgrade successful dialog and Xamarin.iOS activation incomplete error.

Environment Details:
Windows 8x64
VS2010 & VS2012
X.iOS 1.0.890 (1e232f00)
X.A 4.6.00043 (a3d43dc7)
Comment 1 Dominique Louis 2013-05-12 19:31:20 UTC
Hi Peter,
  What is the expected behaviour in this scenario?
Comment 2 Peter Collins 2013-05-13 14:45:14 UTC
Any scenario that ultimately results in a successful activation should only display one activation succeeded window, and prompt for a restart of VS.
Comment 3 Dominique Louis 2013-05-20 08:21:01 UTC
Hi Peter, I tried to reproduce this over the week-end and again this morning and it behaves correctly. Namely When logged into xamarinqa+nostations@gmail.com I get the error that all licenses are in use, then when I relogged back in with dominique11@xamarin.com, it just displayed the activation dialog and restarted without any other messages.

Could you please retest with latest from wrench.

Comment 4 Peter Collins 2013-05-20 14:34:16 UTC
I have retested with the current HEADs of master, and I am seeing different behavior for android and iOS cases. However, both cases still fail as described using the steps listed in the description.

With Xamarin Android, after first failing and then successfully activating, the user is *not* prompted to restart, and the user is continuously shown the "Activation Code in use" window even when they have a valid license on disk [0]. In this case, it looks like the IDE does not recognize that a successful activation has occurred, and refuses to load an android project until the user manually restarts VS.

With iOS for VS, after first failing and then successfully activating, the user *is* prompted to restart their visual studio instance, but they are also shown the "Activation Code in use" at the same time [1]. In this case, the IDE does recognize that the user has successfully activated, and prompts for a restart of the IDE; however the user is *still* shown the activation code in use error window on successful activation.

[0]: XA:    http://screencast.com/t/pso0InacfV
[1]: XIVS:  http://screencast.com/t/bxEq0IJz

VS2010 and VS2012
XIVS (master - 3bac7b36)
XA (master - e7390022)
Comment 5 Dominique Louis 2013-05-23 05:34:42 UTC
I'll have to look at your screencasts and try again.
Comment 6 Dominique Louis 2013-05-28 11:22:05 UTC
A more robust check should be performed in  this commit - https://github.com/xamarin/XamarinVS/commit/562bb2a297a709d5613ee8729778689fc0eb41e2
Comment 7 Atin 2013-07-15 15:31:54 UTC
Today, We have checked this issue with following builds:

Windows 7
MFA 4.8.0004
MTVS 1.3.227
VS 2010

With MFA after user login with valid license having workstation available on ide, it doesn't  prompt to restart, and the user is continuously shown the
"Activation Code in use" window even when they have a valid license on disk.
here is the screencast for the same: http://screencast.com/t/RfGHkllocnv 

With ios after user login with valid license having workstation available on ide, it prompts to restart VS with OK button, after restarting VS when we again try to reload the project then project loads successfully without any error message. 

As per our understanding its working fine for ios, But issue is still exists for MFA.

Hence reopening this issue w.r.t MFA.
Comment 8 PJ 2013-07-16 10:39:44 UTC
Ok, this isn't a blocker, we'll get this for 4.8.x.
Comment 9 PJ 2013-11-19 16:38:27 UTC
This bug was targeted for a past milestone, moving to the next active non-hotfix milestone.
Comment 10 Bojan Rajkovic [MSFT] 2014-08-27 11:13:14 UTC
Not an activation service bug.
Comment 11 asimk 2015-07-22 14:22:52 UTC
Now feature has been closed. Hence closing this issue.