Bug 10190 - Crash on device and simulator after upgrade to Monotouch 6.1
Summary: Crash on device and simulator after upgrade to Monotouch 6.1
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: 6.1.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2013-02-09 06:25 UTC by Jochen Hansmeyer
Modified: 2013-03-07 09:54 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Jochen Hansmeyer 2013-02-09 06:25:07 UTC
Crash appears in code below. No diagnostics is given, no exception, app just disappears. Debugger is not able to show "entry". Code worked before upgrade to 6.1.

private Dictionary<string,HistoryEntry> entriesById = new Dictionary<string, HistoryEntry>();


foreach ( HistoryEntry entry in entriesById.Values ) { 
  if ( segment.check ( entry ) ) save = true;

Crash report on simulator: 

Process:         Rowing [29055]
Path:            /Users/USER/Library/Application Support/iPhone Simulator/*/Navigator.app/Rowing
Identifier:      Rowing
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  launchd [141]

Date/Time:       2013-02-08 16:29:21.004 +0100
OS Version:      Mac OS X 10.7.5 (11G63)
Report Version:  9

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000bf7ffb70

VM Regions Near 0xbf7ffb70:
    Stack                  00000000b041f000-00000000b04e8000 [  804K] rw-/rwx SM=COW  
--> Stack                  00000000bc000000-00000000bf800000 [ 56.0M] ---/rwx SM=NUL  
    Stack                  00000000bf800000-00000000c0000000 [ 8192K] rw-/rwx SM=COW  

Application Specific Information:
iPhone Simulator 369.2, iPhone OS 6.1 (iPhone (Retina 4-inch)/10B141)

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   Rowing                        	0x00654d52 GC_clear_stack_inner + 18
1   Rowing                        	0x00654d92 GC_clear_stack_inner + 82
2   Rowing                        	0x00654d92 GC_clear_stack_inner + 82
3   Rowing                        	0x00654e35 GC_clear_stack + 133
4   Rowing                        	0x0064fc85 GC_malloc_atomic + 165
5   Rowing                        	0x005c635f mono_string_new_size + 95
6   Rowing                        	0x005f461a ves_icall_System_String_InternalAllocateStr + 26
7   ???                           	0x0b2d87a6 0 + 187533222
8   ???                           	0x0de0a6e0 0 + 232826592
9   ???                           	0x13f4e120 0 + 334815520
10  ???                           	0x13f4dec4 0 + 334814916

Crash report on device: 

Incident Identifier: 4E8D7D42-33B3-4DEE-B322-CE9B97E96756
CrashReporter Key:   d5a2899480715e7addab45e03d8f054dbdaadd7f
Hardware Model:      iPhone4,1
Process:         Rowing [3241]
Path:            /var/mobile/Applications/FF6F385B-5A93-424C-862A-5350BEC40FBA/Navigator.app/Rowing
Identifier:      Rowing
Version:         ??? (???)
Code Type:       ARM (Native)
Parent Process:  launchd [1]

Date/Time:       2013-02-09 11:53:33.576 +0100
OS Version:      iOS 6.1 (10B142)
Report Version:  104

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Crashed Thread:  0

Thread 0 name:  Dispatch queue: com.apple.main-thread
Thread 0 Crashed:
0   libsystem_kernel.dylib        	0x3b2e4350 0x3b2d3000 + 70480
1   libsystem_c.dylib             	0x3b25b11e 0x3b22c000 + 192798
2   libsystem_c.dylib             	0x3b29796e 0x3b22c000 + 440686
3   Rowing                        	0x01b2fdfc 0x1000 + 28503548
4   Rowing                        	0x01b69edc 0x1000 + 28741340
Comment 1 Jochen Hansmeyer 2013-02-10 12:29:08 UTC
Problem solved, was not ending recursion. But is it expected, that debugger does not catch this situation ?
Comment 2 Rolf Bjarne Kvinge [MSFT] 2013-02-11 08:28:54 UTC
Stack overflows are notoriously hard to detect and provide information for (due to the fact that no code can execute on the thread where this happens), so there are unfortunately cases where the process will just exit.
Comment 3 narayanp 2013-03-07 09:54:47 UTC
As per above comments changing the status to Verified.